ECM/Transmission problem for 2001-2003 RAV4 - Page 3 - Toyota RAV4 Forums
Recall

Find out about the history of your next vehicle and learn how to track the history of your current vehicle.


User Tag List

Reply
 
LinkBack Thread Tools
post #21 of 607 (permalink) Old 01-12-2009, 12:12 AM
Junior Member
 
Join Date: Dec 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by oxymoron
I do not know where you found that reset helps. From what I have read it does not.

I have found a a site http://www.rav4ecm.net/

Read it, HTH
My brother has done it cost him under $50 to do and it has not played up in over 1 year. You are right hwoever, it maybe come back over time. But he saved $1500.

next time it feels like it comes back..just manually reset it again ur self for free.
kwax is offline  
Sponsored Links
Advertisement
 
post #22 of 607 (permalink) Old 01-15-2009, 07:21 PM
Senior Member
Country: eguy's Flag is: United States
 
eguy's Avatar
 
Join Date: Jun 2007
Location: California
Posts: 250
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
I think I had this done because I got a letter in the mail a while back telling me to take the car into the dealer right way for an ECU reflash. Can someone explain what a harsh shift is?

My Album

2012 RAV4 Limited Pyrite 3.5L V6 4WD 5DR
[Sold] 2008 RAV4 Gold 3.5L V6 4WD 5DR
[Sold] 2001 RAV4 Silver 2.0L 2WD 5DR
eguy is offline  
post #23 of 607 (permalink) Old 01-22-2009, 08:40 PM
Junior Member
 
Join Date: Jan 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
ECM/Transmission issue

I just filed a complaint with the FTC regarding this issue. I urge anyone else with the transmission/ECM problem to do the same. Perhaps if the FTC gets enough complaints, something will come of it.

https://www.ftccomplaintassistant.gov/
ksmith2263 is offline  
 
post #24 of 607 (permalink) Old 02-02-2009, 08:53 AM
Junior Member
Country: bitonw's Flag is: UK
 
Join Date: Jun 2007
Location: Surrey
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
this problem is this a world wide problem or only applies to USA sold vehicles?

i have 2 of those boxes 1 5-drs from 2001 and 1 3-drs from 2003 uk the UK.
bitonw is offline  
post #25 of 607 (permalink) Old 02-02-2009, 12:53 PM
Junior Member
 
Join Date: Aug 2008
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
AFAIK it is world-wide.
oxymoron is offline  
post #26 of 607 (permalink) Old 02-02-2009, 06:47 PM
Junior Member
 
Join Date: Jan 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
I dont know if my car is having the same problem as the ECM issue. My 2001 rav4 4wd can't shift to higher gear if I cold start it in the winter. I think after it shifted to 2nd or third gear, it would just stuck at that gear. I can only go up to 40mph, even if I push the car near 4000rpm. In the summer, I have no problem with it at all. I don't drive it that much, most of the time its a short distance to my job place, only have 40k miles on it. Recently I just had a complete flush of the transmission fluid done at my local dealer.
HooH is offline  
post #27 of 607 (permalink) Old 02-02-2009, 07:57 PM
Advanced Member
Country: Carbon's Flag is: United States
 
Carbon's Avatar
 
Join Date: Jan 2009
Location: NE Illinois
Posts: 4,054
Thanks: 7
Thanked 181 Times in 171 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by HooH
I dont know if my car is having the same problem as the ECM issue. My 2001 rav4 4wd can't shift to higher gear if I cold start it in the winter. I think after it shifted to 2nd or third gear, it would just stuck at that gear. I can only go up to 40mph, even if I push the car near 4000rpm. In the summer, I have no problem with it at all. I don't drive it that much, most of the time its a short distance to my job place, only have 40k miles on it. Recently I just had a complete flush of the transmission fluid done at my local dealer.
So when did the symptoms appear relative to the flush?

First flush? How many miles on the odometer?
Carbon is offline  
post #28 of 607 (permalink) Old 02-03-2009, 09:15 AM
Junior Member
Country: bitonw's Flag is: UK
 
Join Date: Jun 2007
Location: Surrey
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
when cold also my box stays in 2nd or 3rd gear but changes to higher when the engine is warming up. this happens after about 2 miles of driving. i think it's to get the engine / cat quicker to working temp. may be your sensor isn't working correctly and the ecu things that the engine is still cold?
bitonw is offline  
post #29 of 607 (permalink) Old 02-04-2009, 08:25 PM
dmakr
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
tranny

I had this happen 2 me about a year back. The car would shudder and not shift into the next gear or shift like it was being rammed from behind. I called Toyo and they said probably needs a new tranny (140000km on my car). I didnt even know about the ECU problem !! I ended up going to a tranny shop and it was a $5000 repair. Toyo woulda done it for $7000. Welcome to the RAV 4 world. This is pooor engineering in my opinion !!

Also, this year, my car has 183,000km, and there is major sludging in my engine. This caused an oil pump to my engine to fail, which lead to the cam gear on my VVTi enging not receiving lubrication. This ultimately led to the gear not functioning properly. Everytime the VVTi (variable valve timing) comes on, it causes the chain to stretch and knock against the valve cover. After opening up the engine and showing me what exactly is happening, I agreed and $2500 later, it's like a new car !! Im very disappointed in the amount of $ we all have to put into these vehicles post warranty (especially since it is not due to neglect of servicing).
 
post #30 of 607 (permalink) Old 02-04-2009, 09:15 PM
Senior Member
 
Join Date: Feb 2006
Location: Philippines
Posts: 225
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: tranny

Quote:
Originally Posted by dmakr
Also, this year, my car has 183,000km, and there is major sludging in my engine.
dmakr, may we know what type, brand, viscosity oil was being placed in your Rav when the sludging happened? Thanks.

Year of the Ox!
Autobeat is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome