reset check engine light - Toyota RAV4 Forums
4.1 General Discuss anything RAV4.1 related that doesn't fit in the categories below.

User Tag List

 
LinkBack Thread Tools
#1 (permalink) Old 03-19-2007, 10:56 AM
Junior Member
 
flht's Avatar
 
Join Date: Mar 2007
Location: Québec
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
reset check engine light

anybody can tell me,wath is the fuse I can remove for reset my check engine light,I know I can disconnect the battery but if somebody can tell me the fuse to remove,I will be do that and I will not have to reprogam my clock and radio.

Thanks flht
flht is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-19-2007, 11:55 AM
Member
 
kikemt's Avatar
 
Join Date: Dec 2005
Location: Long Island, NEW YORK
Posts: 135
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to kikemt
annoying check engine light

well i used to have the same problem a while a go but i fix it.
my mechanic which is japanese very honest man did change sensors in my rav 4 and now since then my rav4 have more power and my light did not come back anymore.

Also y bought for like 40 bucks a scan reader from internet but still i have not use it , let's see 8)
Good luck
kikemt is offline  
#3 (permalink) Old 03-21-2007, 06:19 AM
Advanced Member
 
AussieRAVer's Avatar
 
Join Date: Jun 2006
Location: Victoria, Australia
Posts: 2,904
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Looking at my Haynes manual, if you remove the EFI2 fuse (or EFI) this should reset it... Leave it out for 15 minutes and the reconnect... If the CEL comes back on, go and get the codes read.....

Keep on RAVin.....
AussieRAVer is offline  
#4 (permalink) Old 03-26-2007, 06:50 PM
bbrendan
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Could also be caused by a loose petrol cap. I had my engine light came on fora while and figured out my cap was loose.

I now have a OBDI II reader which is cool for checking what the issue is. Get one off ebay for $40. Or goto a local garage and they can check it for nicks

thanks
 
#5 (permalink) Old 04-11-2007, 03:05 AM
faustas
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
EFI Fuse removal works!

I tried this out tonight as I also have the CEL light on.
I removed the EFI fuse for 10-15 minutes and replaced it.
The CEL light is still on when I switch the car to the "ON" position. As soon as a start the car the light goes off!
So now I can live in oblivion for a little bit (until the light comes on again...)

In the mean time, with the CEL light off, if I try check the error codes, would it return anything?
 
#6 (permalink) Old 04-11-2007, 12:33 PM
Advanced Member
 
Corrupt_File's Avatar
 
Join Date: Apr 2007
Location: BC
Posts: 1,462
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: EFI Fuse removal works!

Quote:
Originally Posted by faustas
The CEL light is still on when I switch the car to the "ON" position. As soon as a start the car the light goes off!
So now I can live in oblivion for a little bit (until the light comes on again...)

In the mean time, with the CEL light off, if I try check the error codes, would it return anything?
All of your lights should come on when you turn the key to on, it shows you the bulbs aren't burnt out. Nothing should show up if the CEL is off, because the vehicle doesn't recognize a problem, if it did, the light would be on!
Corrupt_File is offline  
#7 (permalink) Old 04-12-2007, 06:54 AM
Advanced Member
 
AussieRAVer's Avatar
 
Join Date: Jun 2006
Location: Victoria, Australia
Posts: 2,904
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: EFI Fuse removal works!

Quote:
Originally Posted by Corrupt_File
Quote:
Originally Posted by faustas
The CEL light is still on when I switch the car to the "ON" position. As soon as a start the car the light goes off!
So now I can live in oblivion for a little bit (until the light comes on again...)

In the mean time, with the CEL light off, if I try check the error codes, would it return anything?
All of your lights should come on when you turn the key to on, it shows you the bulbs aren't burnt out. Nothing should show up if the CEL is off, because the vehicle doesn't recognize a problem, if it did, the light would be on!
Not exactly - the codes get stored in a cache... it takes something like 50 start cycles to clear the cache....

Keep on RAVin.....
AussieRAVer is offline  
The Following User Says Thank You to AussieRAVer For This Useful Post:
Saddlebag (07-19-2014)
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome