Vent blower not blowing much - Toyota RAV4 Forums
4.1 Faults & Fixes Got a problem with your RAV4.1?
Share it here and maybe even find a solution.

User Tag List

LinkBack Thread Tools
post #1 of 4 (permalink) Old 11-27-2012, 07:59 PM Thread Starter
Junior Member
Country: kayaker12's Flag is: United States
Join Date: Nov 2012
Location: Washington
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Cool Vent blower not blowing much

Hey all! My heater is not working properly. At full blast, it gives a little blow out of the door side vents, central vents don't do anything. I've googled the issue and one website said to swap the fuse and see if that fixes it. I would prefer not to see a dealer at this time of year but it is getting seriously cold outside and I'd really like to see if I can fix the issue. It does blow warm air, its just no where near as powerful as it has been these past 13 years. Any and all advice is appreciated.
kayaker12 is offline  
Sponsored Links
post #2 of 4 (permalink) Old 11-27-2012, 11:31 PM
Country: fatherer's Flag is: United States
fatherer's Avatar
Join Date: Sep 2012
Location: MASS
Posts: 183
Thanks: 7
Thanked 17 Times in 14 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
sounds like a blower motor resistor. should be $15 on e-bay. Could also be a blower motor. Try the resistor first.
fatherer is offline  
post #3 of 4 (permalink) Old 11-28-2012, 01:02 AM
Advanced Member
Country: doane2u's Flag is: United States
doane2u's Avatar
Join Date: Jul 2012
Location: California
Posts: 847
Thanks: 109
Thanked 41 Times in 37 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
The obvious, you have it set to upper vents?

Have you tried it in recirculation mode to see if it blows stronger.. that would indicated your filter is dirty.

Can you hear the motor blowing strongly, but not much air coming out?

Swapping a fuse won't do anything, unless the blower isn't working at all.

2010 Toyota RAV4 V6 AWD Sport-Sport, Magnetic Grey/Charcoal, Extra Value Pkg, Sport Appearance Pkg, Tow Pkg, BlueLogic hands free
doane2u is offline  
post #4 of 4 (permalink) Old 11-28-2012, 01:00 PM
Advanced Member
Country: Pim's Flag is: Netherlands
Pim's Avatar
Join Date: Oct 2010
Location: Netherlands
Posts: 2,213
Thanks: 6
Thanked 102 Times in 102 Posts
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
I was indeed more thinking into the way of system being clogged up with dirt, leaves and such then a resistor.
Ofcourse it is also possible that the blower motor is about to go or that indeed the resistor has given up.


Driving a BMW318i with LPG at the moment. Had a 2.0 RAV4.1 1997 3drs 4WD euro model w/ABS dual sunroof blue two tone previously.
Pim is offline  
Sponsored Links

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome