Speedo fail and VSC light - Toyota RAV4 Forums
4.2 Faults & Fixes Got a problem with your RAV4.2?
Share it here, and maybe even find a solution.

User Tag List

 
LinkBack Thread Tools
#1 (permalink) Old 01-17-2013, 03:52 PM
Junior Member
 
Godstalker's Avatar
 
Join Date: Jan 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Speedo fail and VSC light

Hi guys,

My 2003 XT3 had suffered a loss of speedometer functionality and the VSC light has come on (no other indicators) - the speedo came back a couple of times then died again. The VSC light was on very dimly for a while and is now bright again, sometimes fluctuating.

I have to assume this is a non-digital electrical problem. I've checked OBD for codes to no avail, I've also tried the jumper method to get flash codes from the lights - they're all fine apart from the VSC light, which just stays lit even in the diagnostic mode! The repair manual doesn't cover this eventuality

One thing that has been suggested is that the recent cleaning (including carpet shampooing) might have left some water sitting in a connection somewhere, causing electrical shorts or poor grounds - do you guys think this is a likely explanation?

I haven't noticed any great loss of stability or power so I don't think the VSC is restricting anything, but the lack of speedometer is a bit of a problem (good job I have satnav, kinda!)

Any advice you might have (including 'Just wait 'till the snow stop and it dries out') would be appreciated!

Ta!
Godstalker is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome