Smart Key-Passenger door not working - Toyota RAV4 Forums
4.3 General Discuss anything RAV4.3 related that doesn't fit in the categories below.

User Tag List

 
LinkBack Thread Tools
#1 (permalink) Old 11-20-2012, 12:32 PM
Fox
Junior Member
 
Join Date: Jun 2012
Location: Michigan
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Smart Key-Passenger door not working

Hi all,

I have an 09 Limited, I noticed yesterday that the passenger door won't lock or unlock when I touch the handle (unlock) or the black button (lock) on the passenger side of the vehicle. It works as one would expect on both the driver's side and the rear door. The car starts normally. I also noticed the lights don't come on when approaching the passenger's side, but do on the driver's side.

Any ideas??? I don't use the passenger handle often, but it annoys me whenever things don't work the way they should!!!!!
Fox is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-20-2012, 12:48 PM
Member
 
Satavtech's Avatar
 
Join Date: Sep 2011
Location: San Antonio
Posts: 183
Thanks: 0
Thanked 13 Times in 13 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
If you remove the interior door panel, you'll find a white connector on the aft portion of the inner door. I would check to make sure that it is securely connected first. It's possible it has come loose and that would explain the symptoms you're decribing.

Rick

2011 Black V6 Limited 2WD
Named (with much input from the kids)
VADER
Satavtech is offline  
The Following User Says Thank You to Satavtech For This Useful Post:
Fox (11-27-2012)
#3 (permalink) Old 11-20-2012, 01:06 PM
Fox
Junior Member
 
Join Date: Jun 2012
Location: Michigan
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Good tip, thanks!!! I will check that connector asap. While I have it apart, is there any way to test the functioning of the handle and/or the antenna?
Fox is offline  
#4 (permalink) Old 11-27-2012, 08:03 AM
Fox
Junior Member
 
Join Date: Jun 2012
Location: Michigan
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Satavtech, you are a life saver! You were dead on with your advice, I took the interior panel off last night, and the connector you referenced was unplugged. Thanks so much for your help!!!
-Fox
Fox is offline  
#5 (permalink) Old 11-27-2012, 06:47 PM
Member
 
Satavtech's Avatar
 
Join Date: Sep 2011
Location: San Antonio
Posts: 183
Thanks: 0
Thanked 13 Times in 13 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
You're quite welcome. Glad it was something that simple.

Rick

2011 Black V6 Limited 2WD
Named (with much input from the kids)
VADER
Satavtech is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome