Backup camera stopped working - Toyota RAV4 Forums
4.3 Exterior Tires, Wheels, Lights, Spoilers, Flares, Bars, Tow Hitches, etc.

User Tag List

 
LinkBack Thread Tools
#1 (permalink) Old 01-03-2013, 11:33 AM
Advanced Member
Country: pico's Flag is: United States
 
pico's Avatar
 
Join Date: Jun 2012
Location: Driftless Zone Minnesota
Posts: 1,016
Thanks: 318
Thanked 63 Times in 60 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
(Thread Starter)
Backup camera stopped working

2011 Limited

Last night the backup camera stopped working. No image whatsoever in the mirror's screen. The lens is clean.

What else might be associated with the camera circuit? Might I expect more problems related to it?

Thank you,
pico is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-03-2013, 03:03 PM
Advanced Member
Country: vanib's Flag is: Canada
 
vanib's Avatar
 
Join Date: Sep 2011
Location: Ottawa, ON, Canada
Posts: 6,420
Thanks: 194
Thanked 496 Times in 446 Posts
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
I don't have a factory camera.
Check the electrical diagrams; might be a blown fuse.
Is your rav still under warranty? May be the dealer would fix it for freem

2008 Base Rav4, 4 Cylinder, 4WD
My upgrades Allen Spare tire Bike Rack
Currently listening to "Gary Hoey" - Ho! Ho! Hoey: The Complete Collection (Chistmas Music with a rocking twist )
vanib is offline  
#3 (permalink) Old 01-03-2013, 04:25 PM
Senior Member
Country: Satavtech's Flag is: United States
 
Satavtech's Avatar
 
Join Date: Sep 2011
Location: San Antonio
Posts: 210
Thanks: 1
Thanked 22 Times in 19 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by pico View Post
2011 Limited

Last night the backup camera stopped working. No image whatsoever in the mirror's screen. The lens is clean.

What else might be associated with the camera circuit? Might I expect more problems related to it?

Thank you,
The circuit also runs through the rear door switch, so you might check to make sure it's working. There is also an odd connector right near the door switch that could be at fault(mine failed and I had to bypass it to keep the camera working). Open the rear door and hit the doorframe about two inches above the door switch, then close the door and see if it's working, if so you have a problem with that connector or the switch.

Rick

2011 Black V6 Limited 2WD
Named (with much input from the kids)
VADER
Satavtech is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome