Dashboard static causes odometer LCD to smear...!!! - Toyota RAV4 Forums
4.3 Interior Stereos, Amps, Soundproofing, Seats, Gadgets, etc.

User Tag List

Reply
 
LinkBack Thread Tools
#1 (permalink) Old 09-28-2012, 02:45 PM
Senior Member
 
Join Date: Jan 2011
Location: Phoenix Metro, AZ
Posts: 421
Thanks: 30
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
(Thread Starter)
Exclamation Dashboard static causes odometer LCD to smear...!!!

For quite sometime I've noticed some smearing of the odometer's LCD. Never knew what was going, but was okay with it since it was temporary... it disappeared overtime. First noticed when I lived in central PA during the cold winter months, i thought it had something to do with the cold weather. However, I now live in AZ and its always warm and sunny.. anyways, i noticed last week when using a microfiber towel to clean the dashboard from dust, static will buildup quickly and causes the LCD to smear temporarily.. see picture..

Clearly this would indicate the boards are not properly grounded. this is not an issue for the LCD display on the OEM radio. Has anyone else encountered this before???
Attached Images
File Type: jpg rav4 static discharge.jpg (203.6 KB, 90 views)
pepepeter is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-28-2012, 03:53 PM
Senior Member
 
Inocense's Avatar
 
Join Date: Mar 2006
Location: Chicago, IL
Posts: 229
Thanks: 6
Thanked 8 Times in 7 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
YEP!!!!!!!!!!!!

YEP!.. Looked EXACTLY like mine... !!!!!!!

I never even thought of static!!!.. I use a micro fiber towel as well.. Hmmm.. But it doesn't happen when I am wiping things down.. It only occurred 4 times.. And it was always right when I turned the vehicle on. No extreme weather so that was not the cause as you said. It would fade each time in about 5 minutes and would appear completely normal after that..

I took photo's and then brought the photo's to my dealer.. They replaced the entire ODO meter within my dash... TWICE.... They said they have never seen a problem like this.. They called Toyota for the second replacement to see if there were any other options.. I said it was pretty odd that the same exact brand new part was bad.. no!??!... So they replaced it again.. They still have no clue and either does Toyota... Keep us up to date if you get anywhere with any of this. For the time being, if you bring the photo's to the dealer, they will replace the part. They have to special order it from the manufacturer and it takes 3 - 7 days typically. Took them about 20 minutes to do the swap out the first time, the second time they wanted to keep it longer to test the connections further, etc so they ended up giving me a loaner for the day..


LCD Dash Issue


2012 Magnetic Grey Metallic Rav4 Sport 4WD 4cyl
Inocense is offline  
#3 (permalink) Old 09-28-2012, 04:30 PM
Senior Member
 
Join Date: Jan 2011
Location: Phoenix Metro, AZ
Posts: 421
Thanks: 30
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
(Thread Starter)
Quote:
Originally Posted by Inocense View Post
YEP!.. Looked EXACTLY like mine... !!!!!!!

I never even thought of static!!!.. I use a micro fiber towel as well.. Hmmm.. But it doesn't happen when I am wiping things down.. It only occurred 4 times.. And it was always right when I turned the vehicle on. No extreme weather so that was not the cause as you said. It would fade each time in about 5 minutes and would appear completely normal after that..

I took photo's and then brought the photo's to my dealer.. They replaced the entire ODO meter within my dash... TWICE.... They said they have never seen a problem like this.. They called Toyota for the second replacement to see if there were any other options.. I said it was pretty odd that the same exact brand new part was bad.. no!??!... So they replaced it again.. They still have no clue and either does Toyota... Keep us up to date if you get anywhere with any of this. For the time being, if you bring the photo's to the dealer, they will replace the part. They have to special order it from the manufacturer and it takes 3 - 7 days typically. Took them about 20 minutes to do the swap out the first time, the second time they wanted to keep it longer to test the connections further, etc so they ended up giving me a loaner for the day..


LCD Dash Issue

WOW thats insane!!!

Im glad I took pictures.. I might just take this up with dealer and have them replace it. It is very consistent.. use a microfiber towel and whaa la.. SMEAR!!!!..

Just to be clear, was this fixed with the new replacement or did it return??
pepepeter is offline  
#4 (permalink) Old 09-28-2012, 04:32 PM
Senior Member
 
Join Date: Jan 2011
Location: Phoenix Metro, AZ
Posts: 421
Thanks: 30
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
(Thread Starter)
Quote:
Originally Posted by Inocense View Post
YEP!.. Looked EXACTLY like mine... !!!!!!!

I never even thought of static!!!.. I use a micro fiber towel as well.. Hmmm.. But it doesn't happen when I am wiping things down.. It only occurred 4 times.. And it was always right when I turned the vehicle on. No extreme weather so that was not the cause as you said. It would fade each time in about 5 minutes and would appear completely normal after that..

I took photo's and then brought the photo's to my dealer.. They replaced the entire ODO meter within my dash... TWICE.... They said they have never seen a problem like this.. They called Toyota for the second replacement to see if there were any other options.. I said it was pretty odd that the same exact brand new part was bad.. no!??!... So they replaced it again.. They still have no clue and either does Toyota... Keep us up to date if you get anywhere with any of this. For the time being, if you bring the photo's to the dealer, they will replace the part. They have to special order it from the manufacturer and it takes 3 - 7 days typically. Took them about 20 minutes to do the swap out the first time, the second time they wanted to keep it longer to test the connections further, etc so they ended up giving me a loaner for the day..


LCD Dash Issue
Agh forgot to ask if you can try the micro fiber test.. if it returns then i think its a short somewhere or bad grounding.. also forgot to mention this earlier:

2008 rav4 sport awd, engine on, wipe dashboard with microfiber towel.. and SMEAR!!!
pepepeter is offline  
#5 (permalink) Old 09-30-2012, 10:20 AM
Senior Member
 
Inocense's Avatar
 
Join Date: Mar 2006
Location: Chicago, IL
Posts: 229
Thanks: 6
Thanked 8 Times in 7 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
When they replaced the meter the first time, the problem once again was apparent and this time directly in front of the Dealer, so THIS time, THEY seen it and took photo's as well. They ordered yet another one and since install the "smear" hasn't come back. I will try the micro fiber towel thing.. Where do you wipe it exactly? Across the clear shield in front of the meter? Steering wheel column? Dashboard above the meter/ODO (I do this all the time with the car off and on so I don't think this is going to give any results)?


2012 Magnetic Grey Metallic Rav4 Sport 4WD 4cyl
Inocense is offline  
#6 (permalink) Old 09-30-2012, 05:54 PM
Senior Member
 
Join Date: Jan 2011
Location: Phoenix Metro, AZ
Posts: 421
Thanks: 30
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
(Thread Starter)
Quote:
Originally Posted by Inocense View Post
When they replaced the meter the first time, the problem once again was apparent and this time directly in front of the Dealer, so THIS time, THEY seen it and took photo's as well. They ordered yet another one and since install the "smear" hasn't come back. I will try the micro fiber towel thing.. Where do you wipe it exactly? Across the clear shield in front of the meter? Steering wheel column? Dashboard above the meter/ODO (I do this all the time with the car off and on so I don't think this is going to give any results)?
wipe across the dashboard directly above the odo, anywhere seems to be sensitive on my rav4, but maybe has something do to with the sensor for the keyless entry (the thing that sticks out on the dashboard). try wiping near that region. The key thing is that you have to hear static discharge as you wipe, otherwise no smearing will occur. I thought this only occurred with the engine off. i was wrong, it occurs with engine off and no key in the ignition.
pepepeter is offline  
#7 (permalink) Old 10-08-2012, 09:43 AM
Senior Member
 
Inocense's Avatar
 
Join Date: Mar 2006
Location: Chicago, IL
Posts: 229
Thanks: 6
Thanked 8 Times in 7 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
I wiped my heart out with micro fiber towels all over the area and I couldn't get the ODO LCD to reproduce the issue. So it is either fixed with the second new one or... My micro fiber towel isn't static'y enough... lol.. I did treat my dash and steering column with an anti static type of sealant.. Ultima Interior Guard Plus 4 oz., interior protectant, rubber & vinyl protectant, rubber dressing

So I dunno.. Hmmmm...


2012 Magnetic Grey Metallic Rav4 Sport 4WD 4cyl
Inocense is offline  
#8 (permalink) Old 10-08-2012, 02:35 PM
Senior Member
 
Join Date: Jan 2011
Location: Phoenix Metro, AZ
Posts: 421
Thanks: 30
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
(Thread Starter)
Quote:
Originally Posted by Inocense View Post
I wiped my heart out with micro fiber towels all over the area and I couldn't get the ODO LCD to reproduce the issue. So it is either fixed with the second new one or... My micro fiber towel isn't static'y enough... lol.. I did treat my dash and steering column with an anti static type of sealant.. Ultima Interior Guard Plus 4 oz., interior protectant, rubber & vinyl protectant, rubber dressing

So I dunno.. Hmmmm...
thanks for trying to reproduce. hopefully the new part fixed it. i took my rav4 to the dealer this saturday for this issue as well as the recall for the airbag sensor, the steering wheel creek, and the bubbling on my rims. The dealer claimed they need to speak with toyota to inquire about the remedy for the dash and rims. I have the extended warranty and it seem as though it may or may not cover the bubbling paint on the rims...
pepepeter is offline  
#9 (permalink) Old 10-11-2012, 11:31 PM
Senior Member
 
Join Date: Jan 2011
Location: Phoenix Metro, AZ
Posts: 421
Thanks: 30
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
(Thread Starter)
Quote:
Originally Posted by Inocense View Post
YEP!.. Looked EXACTLY like mine... !!!!!!!

I never even thought of static!!!.. I use a micro fiber towel as well.. Hmmm.. But it doesn't happen when I am wiping things down.. It only occurred 4 times.. And it was always right when I turned the vehicle on. No extreme weather so that was not the cause as you said. It would fade each time in about 5 minutes and would appear completely normal after that..

I took photo's and then brought the photo's to my dealer.. They replaced the entire ODO meter within my dash... TWICE.... They said they have never seen a problem like this.. They called Toyota for the second replacement to see if there were any other options.. I said it was pretty odd that the same exact brand new part was bad.. no!??!... So they replaced it again.. They still have no clue and either does Toyota... Keep us up to date if you get anywhere with any of this. For the time being, if you bring the photo's to the dealer, they will replace the part. They have to special order it from the manufacturer and it takes 3 - 7 days typically. Took them about 20 minutes to do the swap out the first time, the second time they wanted to keep it longer to test the connections further, etc so they ended up giving me a loaner for the day..


LCD Dash Issue
Inocense, how did you manage to convince the dealer to change out the odo?

They are givning me the run around even though i took them
Pictures and in person they saw it happen. The tech claimed someone must have messed with the wiring or odometer or there is a loose or bad ground (its obviously a bad grand). The tech and dealer claimed toyota would not cover issues related to static. So i gladly walked over to the new rav4 and wiped the dashboard with my microfiber towel and asked where is the smear on this car? The tech claimed static can do a lot of things. I agree!!! But that is why a proper ground is crucial.

Currently the rav4 is at the dealer and im on a prius V loaner. But i have a feeling they are going to push back and say nothing can be done (especially since its a friday).
pepepeter is offline  
#10 (permalink) Old 10-12-2012, 12:09 AM
Member
 
seven_rav11's Avatar
 
Join Date: Nov 2011
Location: CA
Posts: 98
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Guys I'm sorry to say this but what your experiencing is normal. It will always happen unless the static electricity from your microfiber towel will discharge. I am also experiencing this but I dont think that this is a problem with your ODO. The thing is, whenever you rub your towel to any surface like your dashboard it will create a friction and therefore create static electricity. This will only be removed by discharging it to a conductive surface and an example is your ODO LCD. Microfiber Towel uses this static electricity to clean surfaces because it attracts the dusts off your dash board. It works like a magnet(opposites attract).

Rav4 2011 - I4/2wd ( Black )

seven_rav11 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome