Wireing Factory USB? - Toyota RAV4 Forums
4.3 Interior Stereos, Amps, Soundproofing, Seats, Gadgets, etc.

User Tag List

Reply
 
LinkBack Thread Tools
#1 (permalink) Old 12-09-2012, 01:21 AM
Junior Member
Country: JRFugitt's Flag is: United States
 
Join Date: Sep 2012
Location: Texas
Posts: 21
Thanks: 6
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Wireing Factory USB?

I know there is a post somewhere but I cant find it, so sorry! I installed a Myron and Davis head unit in my wife's 2012 Rav4 and everything is great but the USB cable that comes with the unit is too short to run to the factory location. I want everything to appear stock so has anyone cut the end off the stock usb cord (radio side) and cut the end off the USB from the aftermarket radio and wired the two together? Any suggestions would be great. I found an adapter but there is no reason to spend $70 when I can do it for free!

JRFugitt is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-09-2012, 11:37 AM
Member
Country: grmuller's Flag is: United States
 
Join Date: Jun 2012
Location: New York
Posts: 53
Thanks: 13
Thanked 3 Times in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
JR,
Take a look at this adapter.
Vehicle Fit Guide

How is the unit working. I have a 2012 also and was looking at that unit also. Any complaints with it?
grmuller is offline  
#3 (permalink) Old 12-09-2012, 11:55 AM
Junior Member
Country: JRFugitt's Flag is: United States
 
Join Date: Sep 2012
Location: Texas
Posts: 21
Thanks: 6
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Quote:
Originally Posted by grmuller View Post
JR,
Take a look at this adapter.
Vehicle Fit Guide

How is the unit working. I have a 2012 also and was looking at that unit also. Any complaints with it?
For $329.00 it's great! It looks like it's supposed to be there and works good. The nav loads alittle slow and the screens could look more up to date but can't complain for alittle over 300 bones. It's plug and play but on the '12 we have to modify one connector for the steering wheel controls to work. Don't buy the rearview camera just get one off ebay. The GPS antenna has to be mounted external, don't put on radio or under dash it's not strong enough. And of corse if you want use of the usb..... follow wherever this thread ends!

JRFugitt is offline  
#4 (permalink) Old 12-09-2012, 12:20 PM
Junior Member
Country: JRFugitt's Flag is: United States
 
Join Date: Sep 2012
Location: Texas
Posts: 21
Thanks: 6
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
The adapter to me is just a waste of money, why spend 50 to 70 dollars when it can be spliced directly behind the radio in the dash for free! An usb extension wont work because the usable end wont have the mounting cage to put in the factory location.

JRFugitt is offline  
#5 (permalink) Old 12-09-2012, 01:03 PM
Your Humble Administrator
Country: JuneBug's Flag is: United States
 
JuneBug's Avatar
 
Join Date: Nov 2008
Location: Baton Rouge, LA
Posts: 10,959
Thanks: 88
Thanked 1,181 Times in 852 Posts
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Garage
JuneBug is offline  
The Following 2 Users Say Thank You to JuneBug For This Useful Post:
JRFugitt (12-09-2012), ryderjay (04-07-2013)
#6 (permalink) Old 12-09-2012, 06:09 PM
Member
Country: grmuller's Flag is: United States
 
Join Date: Jun 2012
Location: New York
Posts: 53
Thanks: 13
Thanked 3 Times in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Where did you mount the GPS antenna?
grmuller is offline  
#7 (permalink) Old 12-09-2012, 06:52 PM
Junior Member
Country: JRFugitt's Flag is: United States
 
Join Date: Sep 2012
Location: Texas
Posts: 21
Thanks: 6
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Quote:
Originally Posted by grmuller View Post
Where did you mount the GPS antenna?
Had it mounted on top of the radio, then ran it just behind where the driver's side roof rack starts. wanted it in the rear but about a foot too short.

JRFugitt is offline  
#8 (permalink) Old 12-22-2012, 05:17 AM
Member
Country: jingerale's Flag is: United States
 
Join Date: Dec 2012
Location: California
Posts: 94
Thanks: 19
Thanked 6 Times in 6 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
was the unit plug and play? Did it come with a 28 pin? or did you have to modify the connector?
jingerale is offline  
#9 (permalink) Old 01-13-2013, 09:39 AM
Junior Member
Country: srockrav4's Flag is: United States
 
Join Date: Dec 2012
Location: NY, USA
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by JRFugitt View Post
I know there is a post somewhere but I cant find it, so sorry! I installed a Myron and Davis head unit in my wife's 2012 Rav4 and everything is great but the USB cable that comes with the unit is too short to run to the factory location. I want everything to appear stock so has anyone cut the end off the stock usb cord (radio side) and cut the end off the USB from the aftermarket radio and wired the two together? Any suggestions would be great. I found an adapter but there is no reason to spend $70 when I can do it for free!
I'm having the same issue and was wondering if you had a fix. I even bought a cable meant to attach the factory USB to the Myron and Davis unit and couldn't get the USB port to work (e.g., power my phone). Interestingly, the AUX port which is the same wire I believe worked. Any help would be appreciated. Thanks.
srockrav4 is offline  
#10 (permalink) Old 01-14-2013, 07:25 PM
Member
Country: jingerale's Flag is: United States
 
Join Date: Dec 2012
Location: California
Posts: 94
Thanks: 19
Thanked 6 Times in 6 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by srockrav4 View Post
I'm having the same issue and was wondering if you had a fix. I even bought a cable meant to attach the factory USB to the Myron and Davis unit and couldn't get the USB port to work (e.g., power my phone). Interestingly, the AUX port which is the same wire I believe worked. Any help would be appreciated. Thanks.
ok so this part I don't understand. The Aux? the USB is stand alone. Single cable from the port. Not sure why you think the USB has anything to do with the Aux.
jingerale is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome