Whining noise at 40-50 mph solved? (updated on 8/26/10: TSB is out) - Toyota RAV4 Forums
4.3 Mechanical Intakes, Exhaust, Tune-ups, 4x4 system, Suspension, Brakes, etc.

User Tag List

Reply
 
LinkBack Thread Tools
#1 (permalink) Old 05-20-2009, 09:39 PM
Member
 
Join Date: Dec 2006
Location: MD
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Whining noise at 40-50 mph solved? (updated on 8/26/10: TSB is out)

Went to Dealer for oil change and mentioned the whining noise again. The guy told me they need to change the ECM to solve this problem but they need to order the parts. Sounds like he knows what he is doing (They stated the noise was normal one year ago).
Brought my RAV4 in today and had the ECM changed. The noise is much faint now though it is not completely gone. Is there a TSB for this issue came out yet?


Updated on 8/26/2010: :P

The TSB is out. The number is T-SB-0192-10 (cerdit to hsvcara), and the link is:

http://www.mediafire.com/?11dr5qdpxgq0y74 (cerdit to ghen)

the canadian version:
http://www.mediafire.com/?fcd8p419qnuoga6 (cerdit to hans_gregor )

Hope Kelly will put it in the "TSBs" soon.
xurav4 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-21-2009, 07:04 AM
Member
 
Join Date: Feb 2009
Location: Magnolia, TX
Posts: 130
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
I'm not aware of a TSB, but my dealership did mention that Toyota was aware of the problem and was working on a fix. I never heard of a ECM whining, but I guess all things are possible!
INDYMAC is offline  
#3 (permalink) Old 05-21-2009, 07:16 PM
Advanced Member
Country: friendly_jacek's Flag is: United States
 
friendly_jacek's Avatar
 
Join Date: Jun 2006
Location: Alabama
Posts: 2,607
Thanks: 38
Thanked 39 Times in 39 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Whining noise at 40-50 mph solved?

Quote:
Originally Posted by xurav4
Went to Dealer for oil change and mentioned the whining noise again. The guy told me they need to change the ECM to solve this problem but they need to order the parts. Sounds like he knows what he is doing (They stated the noise was normal one year ago).
Brought my RAV4 in today and had the ECM changed. The noise is much faint now though it is not completely gone. Is there a TSB for this issue came out yet?
First time I've heard that. What was the part #?
Are you sure the noise went down? Try again on a hot day with well warmed up engine/tranny. The noise sounds like mechanical/lubrication issue rather than electronics.
friendly_jacek is offline  
#4 (permalink) Old 05-22-2009, 07:43 AM
Member
 
Join Date: Feb 2009
Location: Magnolia, TX
Posts: 130
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
I agree. It sounds like classic gear whine to me. It gets louder as the fluid heats up and thins out. I wish they had used a higher viscosity ATF instead of the WS. But then they wouldn't have been able to advertise the current EPA MPG estimates, would they?
INDYMAC is offline  
#5 (permalink) Old 05-22-2009, 08:17 AM
Member
 
Join Date: Dec 2006
Location: MD
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Forget it. The noise is still there and same as before.
xurav4 is offline  
#6 (permalink) Old 06-11-2009, 11:02 PM
Junior Member
Country: mpeg's Flag is: Canada
 
Join Date: Dec 2008
Location: QUEBEC CANADA
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
had the same problemon v6 2008 limited. the change of 4x4 ecu did not solve the problem. The dealr changed the drive shaft. (alignment problem of the drive shaft. Now it's perfect.

Good luck
mpeg is offline  
#7 (permalink) Old 06-12-2009, 03:49 PM
Super Moderator
Country: RTexasF's Flag is: United States
 
RTexasF's Avatar
 
Join Date: Jan 2008
Location: Rio Grande Valley TX
Posts: 7,162
Thanks: 59
Thanked 375 Times in 320 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by mpeg
had the same problemon v6 2008 limited. the change of 4x4 ecu did not solve the problem. The dealr changed the drive shaft. (alignment problem of the drive shaft. Now it's perfect.

Good luck
Please expound on this. Was the old one faulty? Is this the right front half shaft or were both replaced?. We could really use some more information please.

Old Bird......sometimes wise
2008 Base V-6 front wheel drive
2008 Limited V-6 front wheel drive
Both with Tow Prep Package
RTexasF is offline  
#8 (permalink) Old 06-12-2009, 04:10 PM
Member
 
Join Date: Dec 2006
Location: MD
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Quote:
Originally Posted by mpeg
had the same problemon v6 2008 limited. the change of 4x4 ecu did not solve the problem. The dealr changed the drive shaft. (alignment problem of the drive shaft. Now it's perfect.

Good luck
Is the drive shaft related to the whining noise?
xurav4 is offline  
#9 (permalink) Old 06-12-2009, 09:07 PM
Super Moderator
Country: RTexasF's Flag is: United States
 
RTexasF's Avatar
 
Join Date: Jan 2008
Location: Rio Grande Valley TX
Posts: 7,162
Thanks: 59
Thanked 375 Times in 320 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
If it stopped the whining noise I would think so wouldn't you? More information would help all of us though.

Old Bird......sometimes wise
2008 Base V-6 front wheel drive
2008 Limited V-6 front wheel drive
Both with Tow Prep Package
RTexasF is offline  
#10 (permalink) Old 06-14-2009, 06:49 PM
Junior Member
 
Join Date: Aug 2008
Location: MA
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
i think i have the same problem with the v6sport. I have 21k miles. Around 30-40mph around 1500rpm it makes this whinning noise. If i let go the gas, it fine. If i go greater speeds its fine. Sometimes its very little and sometimes you can clearly hear it. I brought this to the toyota dealer. They told me they called toyota techical board or something and they said its normal. My fear is that i drive alot and i'll hit 36k in no time and this wont be covered in warrenty. Plan to bring it again and have something changed out.
ghen is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome