check engine/vsc/4wd lights - Page 15 - Toyota RAV4 Forums
4.3 Mechanical Intakes, Exhaust, Tune-ups, 4x4 system, Suspension, Brakes, etc.

User Tag List

Reply
 
LinkBack Thread Tools
#141 (permalink) Old 01-03-2012, 02:08 PM
PAK
Junior Member
 
PAK's Avatar
 
Join Date: Jul 2006
Location: Andover
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Unhappy The terrible trio: CEL, VSC & 4WD

I also had the CEL, VSC and 4WD lights. The RAV also exhibited a slight bucking on the highway. Dealer said they pulled about 8 error codes but felt that two engine coils were causing the rest of the code errors. After replacing two faulty coils the rest of the error codes went away. As did about $400 from my wallet.
PAK is offline  
Sponsored Links
Advertisement
 
#142 (permalink) Old 01-03-2012, 03:20 PM
Advanced Member
Country: Dr. Dyno's Flag is: United States
 
Join Date: Jan 2010
Location: Eastern CT
Posts: 3,989
Thanks: 141
Thanked 282 Times in 265 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by PAK View Post
I also had the CEL, VSC and 4WD lights. The RAV also exhibited a slight bucking on the highway. Dealer said they pulled about 8 error codes but felt that two engine coils were causing the rest of the code errors. After replacing two faulty coils the rest of the error codes went away. As did about $400 from my wallet.
Same lights here + 7-8 codes on my reader. Reset the codes and got cyl 5 misfire code. Since it's in the rear bank of my V6 I'll replace all three rear coils. Will also give me two spares for the front at the cost of $120.

Learn about your RAV4, it'll save you $$$.

Fred
2006 RAV4 V6 4WD Red Limited - wife's
2006 Accord V6 Hybrid - Dr. Dyno's - quick as the RAV but +8 mpg
2003 Odyssey V6 - handy people & cargo mover
1999 F-250 4X4 Diesel - snow plow, Bully Dog chip
2001 F-250 4X4 Diesel - truck camper, TS chip, 20' bike/trike dyno trailer
2004 Suzuki DRZ-400S Dual Sport

It's the pedal (or the handgrip) on the right!!
Dr. Dyno is offline  
#143 (permalink) Old 06-19-2012, 08:33 AM
Senior Member
 
gregb's Avatar
 
Join Date: May 2009
Location: montego bay
Posts: 286
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via Yahoo to gregb
my rav4 had the same problem been driving around with all three lights on then a couple days ago i notice that when i start the car and wanted to take it out of park it was not moving i had to be pressing the shift botton. yesterday i was driving the car around and i stop switch it off and when i tried stating it and it would not start i taught it was my battery so i got a jump and it started up ,, this morning i took my car to get the battery check and it was ok running strong so i took it to my electrician i told him i was having an ignition problem as my battery was fine he checked every relay and fuse all was well until i told him to check the switch that was on top of the break pedal , my rav is a push button start & stop while he was there checking the switch i notice i was getting the green light in the start button which was then going on an off , when hi did his check the switch was bad he pulled it up cleaned it up and then put it back in it started working fine all lights went away and i am now looking for where i can get a new switch to buy

2006 Rav4
1998 Rav4
gregb is offline  
#144 (permalink) Old 10-12-2012, 09:18 AM
Member
Country: UWISHU1's Flag is: United States
 
UWISHU1's Avatar
 
Join Date: Apr 2011
Location: Hanover Park, IL
Posts: 191
Thanks: 4
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
well MY fix was short lived, CEL, TRAC and VSC are back on.

CEL = P0606
VSC , flashed 5 then 1 = 51
P/S, flashed 4 then 1= 41
UWISHU1 is offline  
#145 (permalink) Old 10-12-2012, 09:47 AM
Advanced Member
Country: Dr. Dyno's Flag is: United States
 
Join Date: Jan 2010
Location: Eastern CT
Posts: 3,989
Thanks: 141
Thanked 282 Times in 265 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by UWISHU1 View Post
well MY fix was short lived, CEL, TRAC and VSC are back on.
Okay, this post got me to read your "HELP" post for the background.

Let's start over.

First, please put your vehicle info in your signature so we don't have to hunt for it. There are a lot of members with a lot of problems. We can't remember them all!

Second, ignore the Skid Control ECU codes until you fix the CEL code set by the main ECU.

I've found the Skid Control ECU can set many codes before the TRAC, 4WD, or VSC lights appear. And simply restarting the engine often turns them off even tho the 4-13 jumper still shows the same Skid Control ECU codes.

But none of this is pertinent until you resolve the CEL code.

Fred
2006 RAV4 V6 4WD Red Limited - wife's
2006 Accord V6 Hybrid - Dr. Dyno's - quick as the RAV but +8 mpg
2003 Odyssey V6 - handy people & cargo mover
1999 F-250 4X4 Diesel - snow plow, Bully Dog chip
2001 F-250 4X4 Diesel - truck camper, TS chip, 20' bike/trike dyno trailer
2004 Suzuki DRZ-400S Dual Sport

It's the pedal (or the handgrip) on the right!!
Dr. Dyno is offline  
The Following User Says Thank You to Dr. Dyno For This Useful Post:
UWISHU1 (10-12-2012)
#146 (permalink) Old 10-12-2012, 05:15 PM
Member
Country: UWISHU1's Flag is: United States
 
UWISHU1's Avatar
 
Join Date: Apr 2011
Location: Hanover Park, IL
Posts: 191
Thanks: 4
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Dr. Dyno View Post
Okay, this post got me to read your "HELP" post for the background.

Let's start over.

First, please put your vehicle info in your signature so we don't have to hunt for it. There are a lot of members with a lot of problems. We can't remember them all!

Second, ignore the Skid Control ECU codes until you fix the CEL code set by the main ECU.

I've found the Skid Control ECU can set many codes before the TRAC, 4WD, or VSC lights appear. And simply restarting the engine often turns them off even tho the 4-13 jumper still shows the same Skid Control ECU codes.

But none of this is pertinent until you resolve the CEL code.

OK I just got back from clearing the ECU codes with a SCAN tool.
Also discovered the alternator is not putting out the ideal voltage with a load on the charging system. Have to special order a new one so it'll be a few days before I can report back.

2006 Rav 4 Base V6 2WD 3.5 liters of fury!
2011 Mustang GT Brembo Pak
2001 Mustang GT Honey Badger Pak
UWISHU1 is offline  
#147 (permalink) Old 10-12-2012, 07:08 PM
Your Humble Administrator
Country: JuneBug's Flag is: United States
 
JuneBug's Avatar
 
Join Date: Nov 2008
Location: Baton Rouge, LA
Posts: 10,645
Thanks: 77
Thanked 1,109 Times in 802 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage

James
__________________

2008 Limited V6 2WD "The Silver Bullet"



Last edited by JuneBug; 10-12-2012 at 09:42 PM.
JuneBug is offline  
The Following 3 Users Say Thank You to JuneBug For This Useful Post:
DVS (01-07-2013), pico (10-12-2012), Tedaii (01-08-2013)
#148 (permalink) Old 01-07-2013, 12:10 AM
Junior Member
Country: Tedaii's Flag is: United States
 
Tedaii's Avatar
 
Join Date: Jan 2013
Location: OR
Posts: 3
Thanks: 5
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
I did panic...but only a little

So, I have a few things in common with the rest of you here. I have the cursed three lights (CEL, VSC, 4WD) show up after hopping in the car while doing some shopping. I had just been skiing earlier today, and then filled up on my way down from the mountain, and then ran it through a car wash because the car was covered in grime after skiing Oh, and I had the car in for regular maintenance last week and everything checked out fine Of course, there is no mechanic I can call on a Sunday evening. Fortunately I found this forum. So, I know I can at least get to work and then have it checked out later. I am really hoping whatever it is is covered under warranty because I just paid $500 for its 60K service last week. Really, the owner's manual should say something like: don't panic, just call mechanic when you can. Jeez.
Yes, I went out and checked the gas cap. It seems fine, but will make sure the dealer checks it as well.

Teresa
'08 Rav4 Sport V6,My first Toyota (after having minivans for the past 15 years) and loving it.

Last edited by Tedaii; 01-07-2013 at 12:12 AM. Reason: add signature
Tedaii is offline  
#149 (permalink) Old 01-07-2013, 02:29 AM
Your Humble Administrator
Country: JuneBug's Flag is: United States
 
JuneBug's Avatar
 
Join Date: Nov 2008
Location: Baton Rouge, LA
Posts: 10,645
Thanks: 77
Thanked 1,109 Times in 802 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
OK, since you don't have the check engine light, it means a code has been stored in the anti-skid ECU. Probably what happened is some grime or debris you picked up on the way down the mountain got stuck on one of your wheel speed sensors. Once the sensor is cleaned off you should be back to normal.

James
__________________

2008 Limited V6 2WD "The Silver Bullet"


JuneBug is offline  
#150 (permalink) Old 01-08-2013, 12:03 AM
Junior Member
Country: Tedaii's Flag is: United States
 
Tedaii's Avatar
 
Join Date: Jan 2013
Location: OR
Posts: 3
Thanks: 5
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Actually, the CEL did come on with the others. Strange thing happened. I had checked the gas cap before going to bed last night. Today I ended up driving two 2 cycles on my way to work. When I got back in my car to go home, the warning lights had all gone out. My guess is on the gas cap not being tightened properly when I fueled up. I was all set to go to the dealer this evening after work. Now I don't have to What a relief! I didn't even have to disconnect the battery cable since the system seemed to reset itself. Nice to know for future reference.

Teresa
'08 Rav4 Sport V6,My first Toyota (after having minivans for the past 15 years) and loving it.
Tedaii is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome