check engine/vsc/4wd lights - Toyota RAV4 Forums
4.3 Mechanical Intakes, Exhaust, Tune-ups, 4x4 system, Suspension, Brakes, etc.

User Tag List

Reply
 
LinkBack Thread Tools
#1 (permalink) Old 07-30-2009, 12:43 PM
Junior Member
 
Join Date: Jul 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
check engine/vsc/4wd lights

I am new to this forum, and my warning light problem is similar to blangga, but I have an '08 only 5K miles. Fine one day sitting on the driveway, next day lights are one.

Called and scheduled service.. Reading these forums has me a little nervous. I bought a Toyota, thought 2b dependable and reliable, not sure if this was a mistake yet. Time will tell.
MIA1948 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-30-2009, 06:00 PM
Advanced Member
Country: friendly_jacek's Flag is: United States
 
friendly_jacek's Avatar
 
Join Date: Jun 2006
Location: Alabama
Posts: 2,507
Thanks: 27
Thanked 36 Times in 36 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
It could be a number of things. Keep us posted.
friendly_jacek is offline  
#3 (permalink) Old 02-04-2010, 12:51 PM
Junior Member
 
Join Date: Jul 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
(Thread Starter)
Belated Follow-Up

I took our RAV to Toyota Service and they told me that the canister filter needed to be replaced. They had cleared the warning lights, and after a month, they installed the replacement (yeh, it took that long to receive the part), but the lights had come back on during this waiting time.

This work was done during Fall/'09 and I thought all was well until earlier today. After 5 months and 3K miles (8K total), the lights are on again.

I NEVER overfill the gas tank and this problem has always occurred when starting the car. The engine runs rough like a one cylinder misfire and these lights come on after I restart. The RAV sits on our driveway (25-30% grade) and is only driven 1 or 2 times / week for short trips. I tried to learn how to clear the warning lights myself to determine if this failure repeats itself, but have not been able to find a reset procedure that works on our '08.

Any ideas?
MIA1948 is offline  
#4 (permalink) Old 02-04-2010, 01:17 PM
Senior Member
Country: dcarr1971's Flag is: United States
 
dcarr1971's Avatar
 
Join Date: Jun 2008
Location: Pittsburgh, PA
Posts: 254
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
You can supposedly clear the memory by doing what they call a "Vishnu Reset". Disconnected the battery, then hop in the vehicle and depress the brake pedal 10 - 20 times. (This should discharge any residual power in the system.) Finally, reconnect the battery.

Disclaimer: I haven't tried this with my Rav4, but it worked for my Legacy GT and I would think that it should work in this case too.

Dave C.
_____________
2007 Flint Micah Rav4 Sport 4x4, i4
1999 Land Rover Discovery II
2006 Subaru Legacy GT Ltd (Sold) :-(
1998 Subaru Outback Sport
dcarr1971 is offline  
#5 (permalink) Old 02-04-2010, 01:30 PM
Advanced Member
Country: Carbon's Flag is: United States
 
Carbon's Avatar
 
Join Date: Jan 2009
Location: NE Illinois
Posts: 4,002
Thanks: 7
Thanked 165 Times in 158 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: Belated Follow-Up

Quote:
Originally Posted by MIA1948
Any ideas?
A Scanguage II (see link at top of page for a discount offer) can let you read codes and clear some codes.

There are cheaper code readers with less function too.
Carbon is offline  
#6 (permalink) Old 02-04-2010, 05:04 PM
Member
 
Rey4's Avatar
 
Join Date: Oct 2009
Location: No. Virginia
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Is it just me, or has anyone seen this problem crop up more often than not?
Rey4 is offline  
#7 (permalink) Old 02-11-2010, 06:45 PM
Junior Member
 
raptor22's Avatar
 
Join Date: Jun 2008
Location: San Francisco
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quote:
Originally Posted by Rey4
Is it just me, or has anyone seen this problem crop up more often than not?
Nope, it's not just you... I got the same problems in my 07 Sport

2007 RAV4 Sport V6 2WD Flint Mica / 2008 IS250
raptor22 is offline  
#8 (permalink) Old 02-22-2010, 10:51 AM
Junior Member
Country: pakong's Flag is: United States
 
Join Date: Nov 2006
Location: Newport News, VA
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via Skype™ to pakong
Has anyone figured out this problem yet? My 07 RAV4 LTD light up yesterday with this message. The service advisor hasn't called me back yet.
pakong is offline  
#9 (permalink) Old 02-22-2010, 02:37 PM
Senior Member
 
MotoMike's Avatar
 
Join Date: Jan 2010
Location: USA
Posts: 211
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
I think that maybe any fault that causes the check engine light to come on will also throw the vsc and 4wd lights. On mine the cruise would not work either. There are many faults that will cause th check engine light to come on. It needs to be scanned to tell what it is. Auto parts stores will usaully loan you their scanner to make a quick check. Mine was the front of the cat ox sensor.

Regards,
Mike
MotoMike is offline  
#10 (permalink) Old 02-22-2010, 03:15 PM
Junior Member
Country: pakong's Flag is: United States
 
Join Date: Nov 2006
Location: Newport News, VA
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via Skype™ to pakong
Okay thanks. I drove over a basketball in my driveway and popped the ball. After that these three lights came on. Go figure, it might simply need to be reset. I suppose the dealer will soak me anyway.
pakong is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome