AC only works when moving. - Toyota RAV4 Forums
4.4 Mechanical Intakes, Exhaust, Tune-ups, 4x4 system, Suspension, Brakes, etc.

User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-07-2019, 08:43 AM Thread Starter
Junior Member
 
Hydraphile's Avatar
 
Join Date: May 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
AC only works when moving.

Actually, it only works when I first start up the car after a long rest and while the car is in significant forward motion, but it blows hot air if I get stuck in slow traffic or stop at a light, only to blow cool when I get going again. It also cools after a few minutes idling in park. My first thought was something to do with the compressor, but after reading a bit, I wonder if it’s the engine cooling fans not spinning unless I’m moving, and to back this up, the external temperature readout on the dash jumps significantly during those slow traffic periods on the highway when the air blows hot. Replacing the air filter helped only a tiny bit, and the shop said the refrigerant was fully charged when they checked. Anyone else experience this? It’s a 2015 LE. I’m willing to do the work myself if it’s not a difficult access situation.
Hydraphile is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-07-2019, 06:24 PM
Your Humble Administrator
Country: JuneBug's Flag is: United States
 
JuneBug's Avatar
 
Join Date: Nov 2008
Location: Baton Rouge, LA
Posts: 16,215
Mentioned: 34 Post(s)
Tagged: 3 Thread(s)
Quoted: 1753 Post(s)
Thanks: 644
Thanked 2,476 Times in 1,797 Posts
Garage
Yes, sounds like your electric radiator fans are not running. They should run whenever the A/C compressor is running. This will also cause your engine to overheat.

Help RAV4World members help you by providing your car's operating location in your profile page. Climate can cause a RAV4 in Dallas Wisconsin to experience a different set of issues when compared to the same model in Dallas Texas.
__________________

2008 Limited V6 2WD "The Silver Bullet"


JuneBug is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
AC Problem That Defies Logic ravgogo 4.3 Mechanical 11 08-13-2018 12:32 PM
Cheap Remedy for AC Evaporator Core Housing Water Leak to Stop Wet Carpets demoder 4.2 Faults & Fixes 1 09-17-2017 06:53 AM
AC recently stopped working if car is too hot dalang 4.1 Faults & Fixes 9 08-03-2017 01:18 AM
Another AC post. It's HOT and I need help DJM86 4.3 Mechanical 8 07-11-2017 06:09 PM
AC On = Funny Drive. Like being in 2nd Gear osu789 4.1 Faults & Fixes 1 06-22-2016 11:59 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome