Hybrid assistant connection problem - Toyota RAV4 Forums
4.5 Electric RAV4 Hybrid & EV Discuss anything Electric or Hybrid RAV4.5 (2019+) related.

User Tag List

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 04-10-2019, 01:01 PM Thread Starter
Junior Member
 
Join Date: Jan 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Hybrid assistant connection problem

I have a 2017 RAV4 Hybrid and have used Hybrid assistent since 2017 with no problems.

I took my OBD2 adapter to a 2019 Rav4 hybrid for a test drive.

"unknown" and "connection lost" is reported in HA.

Isn't HA compatible to the 2019 Rav4 hybrid?

/Peter
peswe is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-10-2019, 02:12 PM
Member
 
Join Date: Mar 2019
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 52 Post(s)
Thanks: 1
Thanked 17 Times in 16 Posts
I don’t know what hybrid assistant is, but I can only imagine that due to it being an all new motor, it probably either requires an update or a new hardware/software solution.
Exit is offline  
post #3 of 7 (permalink) Old 04-10-2019, 03:08 PM
Member
Country: VonJot's Flag is: Netherlands
 
VonJot's Avatar
 
Join Date: Dec 2018
Location: The Netherlands
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 22
Thanked 29 Times in 21 Posts
In my '18 it won't connect either with same messages. You'll need a different OBD dongle for this particular app i guess. Torque works with my current dongle.

Ordered a 2019 RAV4 Hybrid AWD (XSE HV Premium) in Zircon Silver / Attitude Black.
For now my Black-and-Blue 2018 C-HR Hybrid Bi-tone Premium will do.
VonJot is offline  
 
post #4 of 7 (permalink) Old 04-10-2019, 03:14 PM
Advanced Member
Country: Quickdtoo's Flag is: United States
 
Quickdtoo's Avatar
 
Join Date: Mar 2006
Location: SW Washington
Posts: 4,407
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 963 Post(s)
Thanks: 122
Thanked 979 Times in 821 Posts
Garage
You'll have to wait for an HA update that includes the '19 Rav4, right now only pre-'19 Rav4 are compatible. I had the same issue with Carista, works on our '18 Prius Prime, but not on the '19 Rav4, they said it would be a while before it's fully compatible, you can ask when they will update HA, they have a Facebook page.

https://hybridassistant.blogspot.com/p/cars.html

https://www.facebook.com/hybridassistant/

2019 XLE Premium AWD
Quickdtoo is online now  
post #5 of 7 (permalink) Old 04-10-2019, 03:32 PM
Member
Country: pikeviewer's Flag is: United States
 
Join Date: Dec 2018
Location: Shadow of Pikes Peak
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 64 Post(s)
Thanks: 20
Thanked 49 Times in 34 Posts
I'm very curious about this as well. I sent an e-mail to the developers. I'll let you know the response. I don't have an adapter to try, will order one if the developer says the app will work.

Edit: got a quick response: "Not yet, it’s a brand new model, as you might know."

No word on when it may be covered.
pikeviewer is offline  
post #6 of 7 (permalink) Old 04-10-2019, 03:39 PM
Advanced Member
Country: Quickdtoo's Flag is: United States
 
Quickdtoo's Avatar
 
Join Date: Mar 2006
Location: SW Washington
Posts: 4,407
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 963 Post(s)
Thanks: 122
Thanked 979 Times in 821 Posts
Garage
I used the OBDLink LX on my '16 Ltd HV, worked flawlessly with HA, they have a list of tested OBD adapters.

https://hybridassistant.blogspot.com/p/obd.html

2019 XLE Premium AWD
Quickdtoo is online now  
post #7 of 7 (permalink) Old 04-11-2019, 04:31 AM
Member
Country: VonJot's Flag is: Netherlands
 
VonJot's Avatar
 
Join Date: Dec 2018
Location: The Netherlands
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 22
Thanked 29 Times in 21 Posts
Quote:
Originally Posted by pikeviewer View Post
..."Not yet, its a brand new model, as you might know."
Well, this is a typical BS-answer from a lazy (or budgetless) developer. The Toyota C-HR Hybrid is on the road for almost 3 years now; same system, same problem. They still haven't figured out where the problem lies.
The statement that it's a "brand new car" is not relevant here...

Ordered a 2019 RAV4 Hybrid AWD (XSE HV Premium) in Zircon Silver / Attitude Black.
For now my Black-and-Blue 2018 C-HR Hybrid Bi-tone Premium will do.
VonJot is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Bulkhead Problem - 2018 RAV4 Hybrid DGRAV4 Member Introductions 0 03-03-2019 12:55 PM
Hybrid Assistant and Hybrid Reporter Daali 4.4 Electric RAV4 Hybrid & EV 9 01-03-2018 12:47 AM
2016 Rav4 Hybrid ECU problem already? me2old 4.4 Electric RAV4 Hybrid & EV 2 02-10-2016 03:14 AM
Forbes: 2016 Toyota RAV4 Hybrid Test Drive And Review: The Answer JuneBug 4.4 Electric RAV4 Hybrid & EV 9 12-30-2015 08:27 PM
Toyotas New Hybrid RAV4 SUV Is a Bargain at Only $700 More JuneBug 4.4 Electric RAV4 Hybrid & EV 12 12-19-2015 07:29 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome