Doors locking automatically? - Toyota RAV4 Forums
4.5 Electric RAV4 Hybrid & EV Discuss anything Electric or Hybrid RAV4.5 (2019+) related.

User Tag List

Reply
LinkBack Thread Tools
post #1 of 15 (permalink) Old 05-07-2019, 10:42 PM Thread Starter
Junior Member
Country: WillyNilly's Flag is: United States
 
Join Date: Apr 2019
Location: WA state
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
(Thread Starter)
Doors locking automatically?

Just got my Limited Hybrid on Sunday....upgraded from my 07 Camry as a lifestyle change (and 23mpg....) while jealous of wifeys Prius fuel economy. Waited a few weeks for this car to get delivered to another dealer to send it over in a dealer trade. So for the guy in Spokane that waited a month and half for his XLE, congrats on your new car!

Anyways, there are way many settings to mess with but this one sort of has me puzzled.

Got the vehicle customization to lock doors when shifting from P...Doors don't lock when shifting from park when set this way.

Tried to change it to lock based on speed and it didn't lock during drive of up to 35mph.

But if I lock doors manually (with the control on the driver side door) during drive, they will unlock appropriately when I put it into park. Something I should get checked out? Doesn’t seem to have come up in the hybrid forums? Dealership is supposed to get back to me tomorrow.
WillyNilly is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 05-07-2019, 10:57 PM
Member
Country: rvs007's Flag is: Canada
 
rvs007's Avatar
 
Join Date: Feb 2019
Location: Toronto, Canada
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Thanks: 24
Thanked 11 Times in 9 Posts
Quote:
Originally Posted by WillyNilly View Post
Just got my Limited Hybrid on Sunday....upgraded from my 07 Camry as a lifestyle change (and 23mpg....) while jealous of wifeys Prius fuel economy. Waited a few weeks for this car to get delivered to another dealer to send it over in a dealer trade. So for the guy in Spokane that waited a month and half for his XLE, congrats on your new car!

Anyways, there are way many settings to mess with but this one sort of has me puzzled.

Got the vehicle customization to lock doors when shifting from P...Doors don't lock when shifting from park when set this way.

Tried to change it to lock based on speed and it didn't lock during drive of up to 35mph.

But if I lock doors manually (with the control on the driver side door) during drive, they will unlock appropriately when I put it into park. Something I should get checked out? Doesnít seem to have come up in the hybrid forums? Dealership is supposed to get back to me tomorrow.
It's been mentioned by others that this is the result of something not being set correctly during the PDI by the dealership. I think the remedy is to bring it back to the dealership and have them make the correction.
rvs007 is offline  
post #3 of 15 (permalink) Old 05-07-2019, 11:19 PM Thread Starter
Junior Member
Country: WillyNilly's Flag is: United States
 
Join Date: Apr 2019
Location: WA state
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
(Thread Starter)
Thanks for the quick reply. Am hoping I don’t have to make the 45m drive back (it’s not the closest dealership) when I can go to the one half the distance away.

Been lurking since I decided on this car and have learned a lot of things! Glad to be here!
WillyNilly is offline  
 
post #4 of 15 (permalink) Old 05-08-2019, 10:22 AM
Member
Country: rvs007's Flag is: Canada
 
rvs007's Avatar
 
Join Date: Feb 2019
Location: Toronto, Canada
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Thanks: 24
Thanked 11 Times in 9 Posts
Quote:
Originally Posted by WillyNilly View Post
Thanks for the quick reply. Am hoping I donít have to make the 45m drive back (itís not the closest dealership) when I can go to the one half the distance away.

Been lurking since I decided on this car and have learned a lot of things! Glad to be here!
There's another thread that has a better solution (that doesn't require going back to the dealership):

https://www.rav4world.com/forums/193...matically.html

You need to disconnect the battery for 30 min. to reset the system, then it should work.
rvs007 is offline  
post #5 of 15 (permalink) Old 05-08-2019, 10:45 AM
Junior Member
Country: willee51's Flag is: United States
 
willee51's Avatar
 
Join Date: May 2019
Location: Central Virginia
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Thanks: 1
Thanked 5 Times in 5 Posts
Dealer has one other on the lot, with same problem, auto door locks not working !!!!!

Mine, I went out and disconnected the negative battery terminal, waited 10-min and reconnected

Auto door locks are now working ..... “

2019 RAV4 XSE AWD Black & Silver
willee51 is offline  
The Following User Says Thank You to willee51 For This Useful Post:
Thornezilla (05-13-2019)
post #6 of 15 (permalink) Old 05-08-2019, 11:24 AM
Junior Member
Country: dl_24's Flag is: United States
 
Join Date: May 2019
Location: United States
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Has anyone who has disconnected the battery had any trouble with their backup camera afterward? Pg. 693 in the owners manual seems to indicate it might change your backup camera settings.
dl_24 is offline  
post #7 of 15 (permalink) Old 05-08-2019, 12:50 PM
Advanced Member
Country: Quickdtoo's Flag is: United States
 
Quickdtoo's Avatar
 
Join Date: Mar 2006
Location: SW Washington
Posts: 4,709
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 1064 Post(s)
Thanks: 131
Thanked 1,076 Times in 893 Posts
Garage
Quote:
Originally Posted by dl_24 View Post
Has anyone who has disconnected the battery had any trouble with their backup camera afterward? Pg. 693 in the owners manual seems to indicate it might change your backup camera settings.
Changes can be made with the diagnostic menu if the battery disconnect causes a problem.

https://www.rav4world.com/forums/201...ml#post2671309

2019 XLE Premium AWD
Quickdtoo is online now  
post #8 of 15 (permalink) Old 05-14-2019, 10:07 PM
Junior Member
Country: yatwing's Flag is: United States
 
Join Date: Mar 2016
Location: NorCal
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I just disconnected my battery and the auto locks are now working but unfortunately my parking assist is now malfunctioning. Any ideas anyone?
yatwing is offline  
post #9 of 15 (permalink) Old 05-14-2019, 11:08 PM
Advanced Member
Country: Quickdtoo's Flag is: United States
 
Quickdtoo's Avatar
 
Join Date: Mar 2006
Location: SW Washington
Posts: 4,709
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 1064 Post(s)
Thanks: 131
Thanked 1,076 Times in 893 Posts
Garage
Quote:
Originally Posted by yatwing View Post
I just disconnected my battery and the auto locks are now working but unfortunately my parking assist is now malfunctioning. Any ideas anyone?
As usual, read the manual first, see page 703 on what has to be done after reconnecting the battery.

https://www.toyota.com/t3Portal/docu...f/OM0R010U.pdf

2019 XLE Premium AWD
Quickdtoo is online now  
post #10 of 15 (permalink) Old 05-14-2019, 11:23 PM Thread Starter
Junior Member
Country: WillyNilly's Flag is: United States
 
Join Date: Apr 2019
Location: WA state
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
(Thread Starter)
Dealer couldn't fix it - originally told me it's not a feature for my car (WTF?) so had them check it out. Computer came out and it was set appropriately in techstream. Had them change it to 'by speed' and we went for a loop around the lot where it didn't lock, so they want to set up another appointment. Think I'll suggest the unplugging and replugging in that the interwebs recommended at that visit.

Little worried about unplugging that negative terminal myself with all those things on page 703 that may need to be reinitialized! The dealer did do the customization to open the roof/windows with smartkey, which I'm also worried would be lost with the rest and have to be redone because I can't do that myself.
WillyNilly is offline  
Sponsored Links
Advertisement
 
Reply




  Similar Threads
Thread Thread Starter Forum Replies Last Post
Key fob not chirping when locking the doors t0astercrumbs 4.4 General 0 04-28-2019 06:45 PM
Automatically locking tailgate kschuett0 4.4 Exterior 0 12-03-2018 12:15 AM
Locking doors with remote while door is open spinkay 4.4 Interior 7 07-03-2016 05:32 PM
[2016] Question about the power back door not automatically locking after closing? internalaudit 4.4 General 3 06-03-2016 09:40 PM
Locking doors from lift gate Homer3D 4.4 General 5 04-26-2016 10:49 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome