Won't shift into 4th gear - Toyota RAV4 Forums
4.2 Faults & Fixes Got a problem with your RAV4.2?
Share it here, and maybe even find a solution.

User Tag List

 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 05-14-2017, 11:17 AM Thread Starter
Junior Member
Country: sderwin67's Flag is: United States
 
Join Date: May 2017
Location: north carolina
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Won't shift into 4th gear

not sure what he problem is. just purchased a 2001 rav4. 4 speed auto. 133000 miles. ran fine on the way home. did some maintenance on it. new plugs, oil, drain and fill the transmission. now it doesn't want to go into 4th gear. 60mph and im at 4000 rpms! any suggestions? new info...I just disconnected the battery cable for a few mins. corrected the problem. for now. does this indicate it is a computer issue maybe?

Last edited by sderwin67; 05-14-2017 at 11:45 AM. Reason: new information
sderwin67 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 05-14-2017, 11:35 AM
Member
Country: Bent Nail's Flag is: Canada
 
Join Date: Apr 2017
Location: BC Canada
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 1
Thanked 6 Times in 5 Posts
Your year and others had a problem with the ecm that controls the transmission. Do a search on here in that regard. Other simple things to check. Make sure your overdrive is on, Drive on the highway at highway speed, and with the engine warmed up, press the button several times, rpm should change. turn your heater on full blast, for a few minutes and see if the air is hot. If not then it could be a coolant temp sensor gone bad. The ECM needs to see operating temp before it will shift. Did you use the correct fluid and check the level when warm?
Bent Nail is offline  
post #3 of 10 (permalink) Old 05-14-2017, 11:48 AM Thread Starter
Junior Member
Country: sderwin67's Flag is: United States
 
Join Date: May 2017
Location: north carolina
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
yes. all good. heater blows hot air. several people have mentioned the temp sensor. checked that right away. thank you!
sderwin67 is offline  
 
post #4 of 10 (permalink) Old 05-14-2017, 12:00 PM Thread Starter
Junior Member
Country: sderwin67's Flag is: United States
 
Join Date: May 2017
Location: north carolina
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
did that. all good. found other threads that were very helpful. I just disconnected the battery cable and the problem resolved itself. for now. maybe indicates a computer issue?
sderwin67 is offline  
post #5 of 10 (permalink) Old 05-14-2017, 12:29 PM
Member
Country: Bent Nail's Flag is: Canada
 
Join Date: Apr 2017
Location: BC Canada
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 1
Thanked 6 Times in 5 Posts
well at least you now know that the transmission will shift into 4th, and it was not something you did.
Bent Nail is offline  
post #6 of 10 (permalink) Old 05-14-2017, 12:54 PM Thread Starter
Junior Member
Country: sderwin67's Flag is: United States
 
Join Date: May 2017
Location: north carolina
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
yep. will see how it goes...
sderwin67 is offline  
post #7 of 10 (permalink) Old 05-14-2017, 01:10 PM
Advanced Member
Country: Dr. Dyno's Flag is: United States
 
Join Date: Jan 2010
Location: Eastern CT
Posts: 8,737
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 1191 Post(s)
Thanks: 623
Thanked 995 Times in 874 Posts
Also check your battery voltage with the car running. A weak battery or charging system can cause transmission issues.

Fred
2006 RAV4 V6 4WD Barcelona Red Limited - wife's
2018 Accord Hybrid, Blue Pearl - Dr. Dyno's - 47/47 mpg
2003 Odyssey V6 - handy people & cargo mover
1999 F-250 4X4 Diesel - snow plow, Bully Dog chip
2003 F-250 4X4 - eventual replacement for the '99
2001 F-250 4X4 Diesel - truck camper, TS chip, 20' bike/trike dyno trailer
2004 Suzuki DRZ-400S Dual Sport
1968 Volvo 1800S

It's the pedal (or the handgrip) on the right!!


"If you really believe you get what you pay for there's no such thing as a good deal."
Dr. Dyno is offline  
post #8 of 10 (permalink) Old 05-14-2017, 01:25 PM Thread Starter
Junior Member
Country: sderwin67's Flag is: United States
 
Join Date: May 2017
Location: north carolina
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
battery was dead when we bought the car. jumped it off to start it. will take the battery to autozone to charge for me. appreciate the advice.
sderwin67 is offline  
post #9 of 10 (permalink) Old 05-14-2017, 06:16 PM
Advanced Member
Country: RTexasF's Flag is: United States
 
RTexasF's Avatar
 
Join Date: Jan 2008
Location: Northeast of Dallas TX
Posts: 10,547
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 1088 Post(s)
Thanks: 297
Thanked 935 Times in 766 Posts
Quote:
Originally Posted by sderwin67 View Post
battery was dead when we bought the car. jumped it off to start it. will take the battery to autozone to charge for me. appreciate the advice.
Not only charge but load test after charging. That is mandatory.

2008 Base V-6
2008 Limited V-6
Tow Prep Package & front wheel drive (both)
RTexasF is offline  
The Following User Says Thank You to RTexasF For This Useful Post:
pico (05-14-2017)
post #10 of 10 (permalink) Old Today, 03:27 AM
Junior Member
Country: kayphyzee's Flag is: Nigeria
 
Join Date: Dec 2018
Location: Lagos
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Hi there, I wonder how this was resolved. Got me a 2001 RAV4 in December and it has this same problem. Gear won't shift into 4th. Refurbished ECU corrected jerking reverse.

Look forward to hearing from you.
kayphyzee is online now  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome