Lift Issues - Toyota RAV4 Forums
4.2 D.I.Y. and Modifications Share your RAV4.2 projects and ideas for future mods here!

User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old Yesterday, 10:13 AM Thread Starter
Junior Member
Country: ebertbn's Flag is: United States
 
Join Date: Jul 2017
Location: North Carolina
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to ebertbn
(Thread Starter)
Lift Issues

Hey team,

I have had an OME lift on my 4.2 for a little over a year now and I am experiencing some issues. The main thing is that there is a lot of creaking and squeaking, pretty much all the time. This could have to do with the fact that most of the bushings and stuff are still stock (140k miles). Is that normal?

Also, I was under the impression that the lift would keep my drive line geometry within a relatively manageable spec, but I am starting to have issues with my CV axles. I know that they can go bad due to lifts, but I thought the OME would be relatively worry free. Is this normal?

I also replaced the endlinks on all 4 corners at the same time, but the front ones seem to be completely shot. All 4 ball joints on the front end links are very greasy, as if their boots have busted. I haven't had time to get it up and look at them, this is just from cranking the wheel around and looking at them from the ground. I know that many hard core off roaders with dedicated vehicles remove the sway bars to increase articulation, but as this is my daily driver, that isn't really an option. Could the increase in ride height and articulation cause my end links to blow out prematurely? Has anyone else had this issue with their lifted 4.2? Fortunately they are only like $20/side so not bad to replace, but maybe there is a fix w slightly longer end links?

Thanks guys!
ebertbn is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Today, 07:24 PM
Senior Member
Country: Commando's Flag is: Canada
 
Commando's Avatar
 
Join Date: Nov 2016
Location: Chicoutimi, Québec
Posts: 264
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 60 Post(s)
Thanks: 13
Thanked 51 Times in 44 Posts
Bushings and end-links need to be replaced on any vehicle. If the end-links you installed are greasable like Moog, it's not abnormal if they are greasy. When they are filled, grease may get out of the boots. I personally deleted my end-links and sway bars for better off road articulation.

For the lift; I have OME springs + 40mm spacers since about 3 years... and still no problem with my CV axles... I only replaced two front CV boots. My RAV4 is at around 168,000 miles on the clock.

2001 with 2.4 swap + RAV4.1 transmission (4.93 final drive ratio), RAV4.1 locking center differential, Lexus RX300 limited slip rear diff , Celica GT4 stage 1 Exedy clutch kit, 3" lift kit, Old Man Emu coil-springs, sway-bars delete and BFG MT KM2 235/70/16.
Commando is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Front End Shaking on acceleration only, after 2" front lift Hoop4 4.3 Mechanical 4 04-02-2019 02:06 PM
What size tires and what issues have you had? eodgator 4.1 D.I.Y. and Modifications 85 03-03-2019 01:44 AM
Old Gal, Various issues inteck 4.1 Faults & Fixes 20 12-04-2017 12:29 PM
Automatic Lift Gate Issues rcz115 4.4 General 5 09-13-2016 12:26 PM
2016 Power Liftgate issues - won't lift peridot028 4.4 Electric RAV4 Hybrid & EV 8 07-07-2016 10:15 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome