Options and accessories - electrical issues - Toyota RAV4 Forums
4.3 General Discuss anything RAV4.3 related that doesn't fit in the categories below.

User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 17 (permalink) Old 04-20-2019, 05:54 AM Thread Starter
Junior Member
Country: chumberger's Flag is: United States
 
Join Date: Apr 2019
Location: Greenville, SC
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Options and accessories - electrical issues

I recently purchased a 2007 RAV4. It has been a bit of a nightmare, and it looks like I will have to trade it back in. After I bought it, I added a hitch and had a new stereo installed. Other than the fact that the main computer appears to be possessed, I do love the RAV. My question is, how do I determine whether or not my hitch and stereo will fit into another RAV4? Are all of the third generation models the same?
chumberger is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 04-20-2019, 07:30 AM
Advanced Member
Country: Dr. Dyno's Flag is: United States
 
Join Date: Jan 2010
Location: Eastern CT
Posts: 8,841
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 1214 Post(s)
Thanks: 634
Thanked 1,027 Times in 900 Posts
Yes they are. But I've never heard of issues with a 4.3 PCM. Plenty of 4.2 problems but no 4.3s. What's the trouble with yours?

Fred
2006 RAV4 V6 4WD Barcelona Red Limited - wife's
2018 Accord Hybrid, Blue Pearl - Dr. Dyno's - 47/47 mpg
2003 Odyssey V6 - handy people & cargo mover
1999 F-250 4X4 Diesel - snow plow, Bully Dog chip
2003 F-250 4X4 - eventual replacement for the '99
2001 F-250 4X4 Diesel - truck camper, TS chip, 20' bike/trike dyno trailer
2004 Suzuki DRZ-400S Dual Sport
1968 Volvo 1800S

It's the pedal (or the handgrip) on the right!!


"If you really believe you get what you pay for there's no such thing as a good deal."
Dr. Dyno is offline  
post #3 of 17 (permalink) Old 04-20-2019, 07:49 AM Thread Starter
Junior Member
Country: chumberger's Flag is: United States
 
Join Date: Apr 2019
Location: Greenville, SC
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
After I'd had it for about 3 weeks, the radio acted up; the volume would stutter. Then, 1 day after my 30-day warranty ran out, I tried using the key fob to unlock the car and it wouldn't work. Everything else seemed fine, but when I turned the engine off and pulled the key out of the ignition, everything went haywire. The dash lights started blinking, the radio came back on, the interior lights came on. I couldn't lock the car with the manual lock. It would simply unlock the second I locked it.
I took it to the shop and their first thought was a bad ignition switch. They couldn't find a problem. They ran diagnostics, but it wouldn't turn up any codes. They couldn't reproduce the problem, so they gave it back to me and told me to come back if it happened again. A week or so later, the same thing happened. This time, when I took it in, I dragged the tech out to my car to show him. This time, there were apparently some codes. Their tech worked on it and then they sent it to the dealership to have the main computer replaced. Everything was great for about a month.
It started again; radio stuttering, then the dash lights flashing after I'd removed the key. They had it for a day, couldn't reproduce the issue, sent it to the dealership and they couldn't reproduce the problem. So I got it back again. Four days later, the radio stuttered, then lights flashed after I'd removed the key. This time was different. Only 2 dash lights flashed, but then they stopped. I couldn't get it to do it again, so I waited.
I was happy to work with them and wait for it to happen again, but then, after a rather horrid downpour, my roof started leaking.
My brother is a certified Toyota mechanic and he is stumped. I spoke at length with the tech here and he is stumped. He said that it's a pretty unique issue.
chumberger is offline  
 
post #4 of 17 (permalink) Old 04-20-2019, 09:18 AM
Advanced Member
Country: DL175's Flag is: Canada
 
Join Date: May 2011
Location: Canada
Posts: 2,164
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 468 Post(s)
Thanks: 8
Thanked 320 Times in 280 Posts
It sounds like an electrical problem which started after you replaced the radio and hitch wires. I would take the radio and hitch wires out and put back everything the way it was before to see what happens. There maybe an a bad connection some where or a wire is damaged. There was one member that had electrical problems which was later traced back to the hitch wire being damaged.

2009 RAV4 Sport V6 4WD
2005 RAV4 Base 4WD -sold
DL175 is offline  
post #5 of 17 (permalink) Old 04-20-2019, 09:42 AM Thread Starter
Junior Member
Country: chumberger's Flag is: United States
 
Join Date: Apr 2019
Location: Greenville, SC
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
The hitch doesn’t have a light package, so there are no wires. The first event happened while the original stock radio was in the car. After they replaced the computer and said that the issue was resolved, I replaced the stereo. Then it happened again.
chumberger is offline  
post #6 of 17 (permalink) Old 04-20-2019, 01:17 PM
Member
Country: wevudo's Flag is: United States
 
Join Date: May 2012
Location: CO
Posts: 104
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 11
Thanked 10 Times in 9 Posts
need new battery?
wevudo is online now  
post #7 of 17 (permalink) Old 04-20-2019, 05:21 PM Thread Starter
Junior Member
Country: chumberger's Flag is: United States
 
Join Date: Apr 2019
Location: Greenville, SC
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
No, the battery has been replaced.
chumberger is offline  
The Following User Says Thank You to chumberger For This Useful Post:
Ott. (04-30-2019)
post #8 of 17 (permalink) Old 04-20-2019, 07:21 PM
Your Humble Administrator
Country: JuneBug's Flag is: United States
 
JuneBug's Avatar
 
Join Date: Nov 2008
Location: Baton Rouge, LA
Posts: 16,211
Mentioned: 34 Post(s)
Tagged: 3 Thread(s)
Quoted: 1752 Post(s)
Thanks: 643
Thanked 2,475 Times in 1,796 Posts
Garage
When I first started reading your story, the first thing that came to mind was water getting into the components under the dash. Then when you mentioned the roof leaking, that confirmed it for me. Sometimes the windshield is replaced and not sealed properly, other times the sunroof leaks. There's also a TSB about replacing the vent cowl at the base of the windshield. Usually after the water dries up, the problems go away.

Also, check your cabin air filter and see if it's wet.

Help RAV4World members help you by providing your car's operating location in your profile page. Climate can cause a RAV4 in Dallas Wisconsin to experience a different set of issues when compared to the same model in Dallas Texas.
__________________

2008 Limited V6 2WD "The Silver Bullet"


JuneBug is offline  
post #9 of 17 (permalink) Old 04-20-2019, 08:08 PM Thread Starter
Junior Member
Country: chumberger's Flag is: United States
 
Join Date: Apr 2019
Location: Greenville, SC
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Thanks for the info. I’ll pass it along to the tech. I’m sure he’ll try anything to fix it at this point.
chumberger is offline  
post #10 of 17 (permalink) Old 04-21-2019, 12:58 AM
Senior Member
Country: max5gen's Flag is: United States
 
Join Date: Mar 2018
Location: SoCal
Posts: 261
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Thanks: 1
Thanked 35 Times in 32 Posts
Quote:
Originally Posted by chumberger View Post
I recently purchased a 2007 RAV4. It has been a bit of a nightmare, and it looks like I will have to trade it back in. After I bought it, I added a hitch and had a new stereo installed. Other than the fact that the main computer appears to be possessed, I do love the RAV. My question is, how do I determine whether or not my hitch and stereo will fit into another RAV4? Are all of the third generation models the same?

What is your exact model/trim? Does it have JBL system by any chance? What is that new stereo brand / model or it is another stock unit?


Have you checked the ground connection from the negative battery post to the chassis of the car? It is thick wire and sometimes things get rusted at the point where it connects to the car.

2011 RAV4 V6 Limited
max5gen is online now  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Canadian Accessory options? jbsali 4.5 Interior 6 02-26-2019 01:50 AM
which options, accessories, or packages did you order? fitnessinstbob 4.4 General 15 10-05-2015 02:46 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome