Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a question regarding my 01 manual transmission RAV4 250K miles. After I travel to my destination, if the car doesn't sit for at least an hour , it is very difficult to restart. It has never left me stranded, but I have to crank it repeatedly for a couple minutes. Once it is restarted it seems to run ok. Also the car has NO passing power. When I do give it gas to pass it lags for at least a minute before the car begins to accelerate. Plus I usually have to feather the gas pedal before moving from a dead stop. My guess is something withe the ignition system, but any info would help. Thanks
 

·
Registered
Joined
·
807 Posts
There's a million reasons, but start with the obvious. Have the battery tested, and also get your car scanned at a local autozone or equivalent (free code check). You could have a failing ignition coil w/o it throwing an engine light (I know because I've been there), but again start with your battery. At 250k miles, when were your spark plugs done last? Just curious.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the reply. The battery is good and fairly new. I can crank the ignition on and off for about 2 to 3 minutes and it will finally turn over. I changed the plugs about 2 years ago. I have also changed the ignition coils in the past with ones I got off amazon. Wasn't 100% sure they were genuine. Those could be the culprit.
 
1 - 4 of 4 Posts
Top