Toyota RAV4 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ok guys, I joined the site to get a little insight on my neighbors 01 rav4 4 cylinder... its his daughters car and they've had it a while.. did the whole computer replacement thing for the shifting problems with the transmission. Anyways the car is acting funny, you can crank it up cold and it will idle for 5-10 min get up to operating temp and then it all the sudden just dies, But most of the time it cranks right back up. There are no check engine lights.. nothing.. just kinda skips/ spudders and then dies. The warmer it gets the more often/ sooner it seems to happen. Ive been reading around on here for a past couple of days (nothing but rain).. Does this body style still have the same grounding issues? either way I'll throw some extra grounds on there, cant really have too many. I inspected both grounds, they "seem" to be alright and nice and tight, inside the factory connections. Don't really mean much as I know they car still get corroded inside. I read a different problem about coil spacing on the plug ins, but that was on a 97 car which I assume was a coilpack car the way the guy explained it, as this one has individual coils. Then I also read another one talking about removing the gas cap and that allowing the car to run. I went into the tsb's I didn't see anything that stuck out, I also didn't understand the evap one, if someone wouldn't mind explaining for me?

Any help, thoughts or opinions would b greatly appreciated. Just trying to save the guy a little money if it's something simple. Any other reasons as to y it will just shut off? and there is no set time as to when it will happen.. so its not like a constant continuous happen every min, it could run 5 min one time, a min the next, 10 the next.. time frame does seem to get a little shorter as the car warms up.


thanks Richard
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,732 Posts
You need to get a code reader and see if there are any codes stored in the ECM. If you can't get your hands on a code reader most auto parts stores will read the codes for you. You can have stored codes without the check engine light illuminating. Another possibility is a semiconductor device that is heat sensitive. Something like a camshaft position sensor or crankshaft position sensor could work fine when cold, then open up when hot. But most of these problems would turn on the check engine light and store a code.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I have a code reader... that's y I said it has no stored codes in it or throwing any codes for that matter... I'm at a bit of a loss on it..
 

·
Super Moderator
Joined
·
10,151 Posts
Any kind of a remote starter on it? Mine is set for 5 minutes. Beyond that you're just wasting gas.

Any problem while driving? If not I wouldn't be too concerned since shutting off "automatically" after warming up would be a good thing IMO. Besides do you really need to warm up cars down South?
 

·
Registered
Joined
·
47 Posts
try putting the old ECU back in (if you have it) and see if that problem goes away, then you know the 2nd ECU is bad, unless the first ECU did the same thing...

I'm hoping it had different symptoms.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
already ask on the ecu.. it was sent back for a core charge...


And its not that we need to warm them up, what I mean by that is when the car itself gets to operating temperature. No remote start or anything like that, its just a plain stock rav as far as I can tell. But once reaching operating temperature it consistently cuts off more often and quicker. maybe a mins time (3-4) different times. It cranks, runs, idles, everything fine and then all the sudden its like the key is turned immediately off (key still on obviously)


was hoping at least one person had the same problem here and could point me in a little better direction.. most posts I read the cars are dying with 20-30 seconds.. when this one is cold it will run for 10 min or maybe a bit more before dying the first time.. and then once its warmed up it starts happening more and more and consistently.. keep the suggestions coming thanks..


Richard
 

·
Registered
Joined
·
4 Posts
I don't have suggestions. Just questions to better understand the problem. What would change about the engine when it gets to temp? Would the engine adjust its air intake at temp?
 
1 - 7 of 7 Posts
Top