Toyota RAV4 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Guys
I'm trying to sort an issue with my daughter's 03 2.0 ltr.
It's starts & runs great from cold for as long as you like.
After you've stopped for 5mins or more (to get fuel or duck into the shops for instance) it cranks but won't start. At this point, it's not getting any power to the fuel pump. If you give it a shot of 'start ya *******' it fires & then obviously dies.


I'm thinking ECU but there are no codes.


Anyone come across this issue before?


Thanks
 

·
Registered
Joined
·
22 Posts
Just a guess. There probably is a relay for this. Perhaps it's sticking. Check the fuse box for a fuel pump relay.
 

·
Registered
Joined
·
7 Posts
I had a very similar problem with a 92 honda prelude that took me 6 months to sort out.

It was black with black interior. If it stat out in the sun for a bit in the summer and got really warm inside, it would turn and turn and turn and not start up. Once I left the doors all open for a while and let the interior cool off, it would fire up like nothing happened. It became my mission in life to plan my day around sunshine and finding shade to park in... it sucked....

Step 1 for me was noticing I could not hear the fuel pump prime when I turned to key to ON (not start, but on...). I am not sure if it is something for all cars (I think it is), but when the key goes to the on position there should be a relay that signals the fuel pump to prime the system and you can hear it whirr for a few seconds pressurizing the system. Once I realized that when it was hot and the key went to on, i noticed the Fuel pump would no run...

I thought it was a bad pump, so I replaced it with a performance (Walbor 255 or something like that, back then I used to autocross the car) pump, and that didn't solve the problem.

I found another honda forum (i was on every prelude forum I could find) for accords and found one other person who had the same issue and it was the "Main Relay" that sat behind the dash on the driver side. The soldering for some of the contacts points on the main relay from Honda were done very poorly, and would crack over time. When the car heated up enough they would expand to the point that there would not be enough contact/voltage to complete the circuit to trigger the pump....

Replaced it (like 100 bucks, took maybe 15 min to get to, unhook and replace) and never had the problem again.

I dont know if this is the same for a RAV4, but it certainly sounds like the same problem, and same symptoms, and that the fuel pump is not being given a signal to deliver fuel.

If the RAV4 has a "Main Relay", I would start there. Maybe even pull it out and see if the solder points looked cracked at all. if you know how to solder, you could probably just re-solder them.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks guys
Appreciate the advice.

I have tried a different relay but I'll also check the wiring to the relay in case there's a solder problem

Cheers
 

·
Registered
Joined
·
1 Posts
Hi there, im having exactly the same issue with my Rav 4 D4D 2004, Starts first time every time even in coldest winter day. However once it has ran for circa 20 mins or so, it will crank hard but not start. Needs a good 10 to 15 mins and then it will start again. It has had new starter motor, new ECU, new EGR valve, also has had replacement Crank position sensor and cam shaft position sensor, and still the same.
any advise would be much appreciated.
 

·
Registered
Joined
·
1 Posts
Hi Guys
I'm trying to sort an issue with my daughter's 03 2.0 ltr.
It's starts & runs great from cold for as long as you like.
After you've stopped for 5mins or more (to get fuel or duck into the shops for instance) it cranks but won't start. At this point, it's not getting any power to the fuel pump. If you give it a shot of 'start ya *******' it fires & then obviously dies.


I'm thinking ECU but there are no codes.


Anyone come across this issue before?


Thanks
Hi There from the uk.

Did you manage to fix this problem
 
1 - 8 of 8 Posts
Top