Toyota RAV4 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I routed the video from the OEM rear-view camera to my JVC head-unit recently (thanks to a post on this forum) and that turned out great. Based on that, I decided to replace the OEM Rear View Mirror with camera display as I wanted to have Homelink and a Compass in my mirror. I removed the OEM mirror and installed a GENTEX Homelink/Compass mirror and wired it directly to the 14-pin connector coming out of the headliner so I didn't damage any of the original wiring to the rear view mirror. I used the ground and 12V Acc pins (White/black and blue wires, pin 1 and 2?) to power the mirror and everything seemed to work fine. However, I don't get the feed from the rear view camera anymore when shifting to Reverse. Do I need to jumper some of the other pins to not lose my camera feed? Are there any other potential issues with this setup?
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,889 Posts
Are you SURE you bought the Gentex mirror with video monitor as well as Homelink and compass? They make many varieties with different features.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
No, the new GENTEX mirror does not have a video monitor.

The new mirror is a GENTEX Auto-dim/Homelink/Compass mirror (Model 453) and I am replacing the OEM mirror which has the Video monitor and is Auto-dim.

I just went out in the garage and reinstalled the OEM mirror and the rear camera video plays on both the OEM mirror and the Head-unit.

When I install the GENTEX 453, the video does not show up on my Head-unit.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
It seems like the rear view camera is not getting any power when the GENTEX 453 is installed. When the OEM mirror is installed, video is displaying on the mirror and Head-unit.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,889 Posts
It seems like the rear view camera is not getting any power when the GENTEX 453 is installed. When the OEM mirror is installed, video is displaying on the mirror and Head-unit.
OK, now I get it. I thought the head unit supplied the power to the camera?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
I believe the OEM camera maybe 6v and there is wiring in the OEM mirror that provides 6v power to the camera. If that is true, I need to get 6v power to the camera when the 453 mirror is installed.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
The OEM Rear view camera does need 6V power and if you remove the OEM rear view mirror you will need to install a 12V to 6V voltage regulator to provide that 6V power. I used a L7806 3-terminal voltage regulator and my rear view camera is working properly and sending an image to my JVC head-unit when my Rav4 is in reverse. Also, I now have the GENTEX 453 Homelink/Compass rear view mirror installed and working!
 
1 - 7 of 7 Posts
Top