Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi Guys,
I cant believe im saying this but Ive googled and googled and nothing.

I bought a 97 automatic rav4 awhile back and it runs great for the most part but I found one fault that is kind of worrysome. My Check Engine light NEVER comes on. Not at start up for a split second like the rest of the lights.I'm afraid the previous owner might have done something to hide a bigger problem by doing something so the Check Engine light doesn't come on. (I dont know if thats possible)

My thinking is that I should purposely try to set it off just to see if it will come on but I dont know how. Does anyone know how i can set it off (like pulling a hose or something)

I checked fuses and didn't find any blown. Just to be sure does anyone tell me which ones to check exactly. Ill just replace it anyway. I couldn't find it in the chilton manual.
 

·
Registered
Joined
·
432 Posts
Try unplugging the throttle position sensor, or the engine coolant temperature sensor, they are easy to get at, I can't guarantee they'l trigger the check engine light but they ought to. My guess is a previous owner has pulled the bulb out or deliberately blown it like the previous owner of mine did to the abs light, low life good for nothing.....
Good luck, I hope for your sake I'm wrong!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Stupid previous owner pulled out or never replaced the bulb in the panel. Its going good now. Pain in the butt for a little bulb.
 
1 - 4 of 4 Posts
Top