Toyota RAV4 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi there, first post to the forum. I purchased a 2001 in good overall condition, serviced, with 185,000k. Have had it for about 4 months, lots of driving, no problems. However during the last 10 days or so, it seems I'm having some intermittent problems with it, and was wondering if people in these forums can confirm my suspicion.

The rav sometimes hesitates off the line, doesn't really move at all for a second or too. Not always though, in fact not even usually. Also it seems like it really lacks power on the highway, doesn't want to shift into the highest gear sometimes, especially uphill. This is much more noticeable at higher speeds, and when going uphill.

The rav has had a full tuneup not to long ago, so I suspect the ECU. My questions then are

1) do these symptoms seem familiar for ECU problems? I'm not getting any physical 'clunking' from the transmission yet, just more power loss. Should I take the car to a shop and get it plugged into a code reader to see what fault codes come up?

2) If it is the ECU, where is a good place to send it off to. From my research it seems like Sergei from Brooklyn has done quite a few, but was looking for some reviews from ppl on here. I am located in Vancouver, Canada, but will ship wherever I need to.

Also worth noting that when I purchased the rav, it was from a family friend, and the check engine light had been on for quite some time. They could never figure out why though.

Thank u in advance for the responses, really want to get this fixed.
 

·
Registered
Joined
·
53 Posts
Yes take it in and get the codes read. both hard and soft and post what you get. I have only had one ECM fail and that was because I welded on the truck and did not disconnect the ECM and battery.
 

·
Super Moderator
Joined
·
11,103 Posts
... the check engine light had been on for quite some time. They could never figure out why though.
Seems the car is trying to tell you what's wrong. Are you going to listen and get the codes read as Bent says, or just start guessing and throwing parts at it?
 

·
Registered
Joined
·
2 Posts
re: " lacks power on the highway, doesn't want to shift into the highest gear sometimes, especially uphill. This is much more noticeable at higher speeds, and when going uphill. "

assuming you have a turbo diesel auto - from the above description, it maybe that the turbo isn't kicking in, to check this simply select a gear and take the car up to 4000 rpm, if the turbo suddenly kicks in and the car takes off then we know this is where the problem is ......


and the most likely fix is a simple one ... the vacuum hose end has probably split and is failing to create vacuum to control the turbo ... you can just make out the red arrow on the image. Cut a clean end on the tube and push it back onto the pipe, maybe even cable tie it on. If it works get a length of "diesel leak off hose" and replace the lot.


hope this helps
 

Attachments

·
Super Moderator
Joined
·
11,103 Posts
...assuming you have a turbo diesel auto
Since he's in Canada I doubt it's a Diesel but it would be nice to know for sure.
 

·
Registered
Joined
·
53 Posts
Yes that would work fine. Cdn Tyre also has them (sometimes on sale) as does Lordco, and many other jobbers in the GVR.

Lots of instructions on you tube as well
 
1 - 8 of 8 Posts
Top