Toyota RAV4 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Ok I have the error that points to the upstream air sensor. I am on my 4th one in 2 weeks. The reset lasts less than 4 miles before the check engine light comes back on. I have gone to a couple of the local big box parts stores in Clemmons, and they have been less than no help I have reset the obc2 by unhooking the battery, and I have done the odometer reset trick as well. The sensor is good, so what is the actual issue that is causing the error.
Thanks
 

·
Registered
Joined
·
68 Posts
What's the exact error code (or codes) you're getting? The codes are pretty specific, "points to the upstream air sensor" is very generic - you could mean the MAF sensor, or the air pressure sensor, or the air temp sensor, or the O2 sensor.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 · (Edited)
What's the exact error code (or codes) you're getting? The codes are pretty specific, "points to the upstream air sensor" is very generic - you could mean the MAF sensor, or the air pressure sensor, or the air temp sensor, or the O2 sensor.
Ok, thanks for responding. I am using an Actron CP9125 ( A very limited P.O.S. IMHO) It tells me that there are 2 codes, but will only show me the first one which is a 2238 code which translates to { Oxygen Sensor Pumping Current Circuit Low Bank 1 Sensor 1} I can not get the 2nd code to come up, only this one.
When I clear this code, my Rav4 accelerates in a choppy manner. It seems to have about a 200 rpm fluctuation at idle. However, once the code comes back (only after I stop then restart, like say going into a store to get a drink or something. ) the choppiness disappears, and the idle steadies out to a steady 800 rpm.
 

·
Registered
Joined
·
68 Posts
Googling "toyota P2238 rav4":
Possible causes
- Faulty Air/Fuel Sensor Bank 1
- Air/Fuel Sensor Bank 1 harness is open or shorted
- Air/Fuel Sensor Bank 1 circuit poor electrical connection

Since you've already replaced the sensor, you'll need to check the wiring back to the ECU.

There's also a TSB for 2004s. It doesn't mention 2005s, but perhaps if your's is an early one...
 
1 - 4 of 4 Posts
Top