Toyota RAV4 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi All,

I just had my engine rebuilt and my test drive of the car went fine. Engine idles and sounds very good, drove well. Second day of driving i noticed first at a stoplight the rpm's would jolt down slightly causing a jerk/bump feel in the vehicle. i have now noticed this while driving with it feeling more like a slight loss of power. I doubt this is transmission as it happens at idle. Checked for codes, shows no codes. Added some fuel injector cleaner still is happening. I think I will add more on my next fill up and 91 and see if that cleans anything out along with a sparkplug change.

Any ideas what can be causing this?
I have read many posts but nothing seems to match 100% and want to be an informed customer so I am not taken if I give this back to be fixed.

Thanks in advance!!!

Tom R
 

·
Registered
Joined
·
162 Posts
its assumed you have the 2AZ-FE and was rebuilt under the ZE7 warranty enhancement by Toyota? It's hard to say with out more info, at cold start up or warm up/driven?, did you go for the $XTRA'$ the repairing dealership would recommend at your cost? After my rebuild i did the extra's that i could do myself.......alternator was failing, serp belt had 40,000 miles on it and then it occurred to me after all this
excessive oil burning condition that the Air/Fuel ratio(upstream) and O2(downstream)eating all that soot
were clogged, additionally all the engine management systems need to be "relearned" , I would replace both of those components and clean the TB, intake and the MAF, additionally go buy an air filter from a Toyota dealership and then let the engine management "relearn".......try that route.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks for the response!

I have the base 2006 engine not sure how to tell what model it is. It was rebuilt by a local garage that i have no clue if they are any good but my hunch is they are not. He was going to put in a used engine, checked 3 engines they all had tolerances out of whack and returned them all. He then rebuilt mine that was destroyed from the oil consumption issue that is well known. I dont know what the ZE7 warranty enhancement is but it was my moms car before and mine for the last 2 years and i have no records so i am sure when talking warranty if i dont have a receipt for one of my 100's of oil changes then they void any accountability from their end and I pay for it or spend money going after them in court. The car only has 88,000 miles on it. The issues can happen at any time cold/warm/moving/idle. You are far more mechanically inclined than myself so I am unsure of some of what you discuss above. The Air/Fuel is what part of a tuneup is correct? How do you reset the engine management system or is that something it does on its own after time What is TB i assume not tuberculosis :) throttle something? I checked the airfilter it looks pretty good. I bought some top of the line Bosch spark plugs i want to put in but afraid with my luck i'll break the old ones off trying to remove.

BAck in the day i had installed water pump, new oil pan wish i would have learned brakes from someone. I can get around a little bit but recently with work i dont pay any attention but now out of work i want to know what i can do before i take it back .....

Thanks any additional thoughts directions?

Appreciate it!

Tom
 

·
Registered
Joined
·
7,916 Posts
Your car might could still have been covered. It might be hard to prove excessive oil use unless your mechanic did a similar oil test or writes a letter on your behalf.
 

·
Registered
Joined
·
8,526 Posts
You might want to drive it for a few days to see whether the problem disappears, gets worse, or remains the same. As a previous post suggests the engine management system may simply need to adjust itself. If the problem doesn't disappear on its own then suggest that you return to the shop which did the rebuild and have them sort it out. Perhaps a wire wasn't securely reattached and may have become disconnected, for example.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Thanks for the input. I will let the gas get down a bit more add 91 or get even better gas and add in fuel injector cleaner with sparkplug change. If it doesnt get better i'll take it back, just hope to have a few ideas of what it could be so he doesn't jerk me around. When i called around for rebuilt costs, they said toyota factory 3 year warranty engine installed was 6,000 to 7,000 for that i might as well buy a new/used car. This mechanic was going to do a used engine for 1700 or mine rebuilt for 2400 after not finding a reliable used one he rebuilt mine and we settled on 2,000 which i felt is very reasonable assuming it works and i dont have to fight this for years going forward. I find it hard that i have this issues and no codes being thrown, wondering if he removed sensors so it wont throw codes or turn light on...not sure..

Thanks guys as always any advice is great and helpfull.

Tom R
 

·
Registered
Joined
·
162 Posts
alot going on there?.......ZE7 >Excessive Oil Consumption on 2AZ-FE Engine LSC ZE7 | TOYO Headquarters

my vehicle had no oil service documented records from any dealership,j_lube or anyone, just DIY for 90,000 miles every 5k as noted in owners manual , i'm the 2nd owner of my RAV, purchased at 55,000....private sale, now at 190,000 after engine rebuild by a dealership that did not sell the car, so it doesn't really matter.
could have just got the rebuild, as outlined by the noted warranty....free! but i knew going into to this i wanted it done right so i paid the $xtras$,including what i wanted, such as new engine mounts. just search this forum for rough idling, low idling .....TB=throttle body/intake, real common issue, needs to be cleaned when this occurs. bosch plugs? maybe in an audi or european car. what ever comes out, put back in......plugs. air/fuel ratio sensor looks like an oxygen sensor, it at the front of engine exhaust manifold at the cat-port....its easy to extract it you remove the heat shield from that location and just trace the wiring harness up to the electrical connection, should be 4 wires with a heat sleeve on it.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Well based on that enhanced warranty until 10/31/16 I am going to write a letter today send it out tomorrow. Question is this does that mean the letter has to be in to them by 10/31 or the vehicle repairs done by 10/31? The link to the enhanced warranty did not indicate. My mechanic is going to make a note of the excess oil consumption and lack of any light prior to engine seizing. I am at least hoping for some reimbursement for the repairs made on the engine rebuild. Really is sad that I got no letter for this or any information regarding it, my father in law even asked his buddy at Toyota and he never mentioned it, go figure.


Regardless I noticed today upon cold start the engine rough idled a bit, but upon pushing excelerator it misses or stutters and smells rich. By tomorrow i'll put 91 or more in with FI cleaner and spark plug change then go after it if it continues.

Thanks

Tom R
 
1 - 8 of 8 Posts
Top