Toyota RAV4 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Has anyone heard a noise coming from the back of the vehicle that doesnt start until about 40 mph. I have replaced the wheel hubs and put new brakes on front and back. I also replaced both 02 sensors and check engine, vsc and traction control lights have came back on. Any ideas on either of these problems?
 

·
Registered
Joined
·
1,017 Posts
That is alot of codes. Most deal with your evap system. I'd go down there and look for damage. Did you run over something recently.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
No i haven't run over anything and to be honest i think all these lights were on before i bought it and the people had just reset it
 

·
Registered
Joined
·
2,494 Posts
No i haven't run over anything and to be honest i think all these lights were on before i bought it and the people had just reset it
How long have you owned it? You can reset the ECU to shut those codes off, but if the original problem that caused them in the first place is still there, the codes will come back usually in a day or so.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
I bought it beginning of march 2016. I have reset the codes using a cen-tech OBDII/EOBD that i bought at harbor freight and i have also disconnected my negative on my battery for 15 minutes. Is there another way to reset it?
 

·
Registered
Joined
·
3,689 Posts
You can clear codes all day long but will comes back if the problem is not fixed. You need to take it to a mechanic if you don't know how to fix the problem. A simple code reader is a general tool to find a problem. Some times the problem is hard to determine and that is why the mechanics have those very expensive computer diagnostic machines to determine exactly what the problem is. You also need technical skills to trouble shoot and test parts are working or not.
 
1 - 7 of 7 Posts
Top