Toyota RAV4 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, we recently purchased a 2007 rav 4 with 91,000 miles from a friend. The vehicle needed some work. We replaced the brakes and rotors front and back. We also changed all tires and did a 4 wheel alignment. When we drive it between 35 to 40 mph and NOT all the time it makes a shudder, vibration sound and sometimes you can feel it in the gas pedal. Our mechanic said to bring it to a very good transmission shop. The transmission shop looked at it and recommended changing the torque converter and transmission fluid and gaskets for the transmission. We did all this and after a few weeks of being at the 2 mechanics it's still doing it. I have read a few other posts about similar problems and all have vague solutions. Can anyone recommend anything else, please we have drove this vehicle a total of 60 miles since buying it. We are beyond frustrated. The transmission shop doesn't know that the problem is still not fixed. They open on Monday morning. Thanks
 

·
Registered
Joined
·
2,617 Posts
The only thing is take it back to the transmission shop. You spent a lot of money so this was the fix. I hope WS fluid was used.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I feel like they don't even care. Yes they did everything correctly but I am concerned that we didn't need the torque converter and it's something else. You are correct the labor charges were expensive. Just frustrated and want to bang our heads up against the wall.
 

·
Registered
Joined
·
7 Posts
My girlfriend has a 2003 in her RAV4 did that shaking and shuttering and she was told to get the tires rebalanced after that it was fine so check the balance of your tires and your rims that may help
 

·
Registered
Joined
·
5 Posts
And this is why I won't sell a car to a friend, haha! Sorry you're going through this. I'm having some similar problems. Things that might be interesting to know, is it vehicle speed or engine rpm related? Does it do it at the same speed if you are in a different gear so a different engine RPM? Maybe look into whether an updated 4 wheel drive ECU would help, I know there was an updated part number and some people have fixed similar issues with that. Maybe drive it with the 4wd ecu unplugged? Good luck, keep us updated!
 
1 - 5 of 5 Posts
Top