Toyota RAV4 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi guys, I'm new to the forum. I own a 2007 Toyota RAV4 4 cylinder automatic transmission. Recently, I was driving and the car's gear shift just stopped working. The engine still revs up just fine but the car doesn't accelerate at all and just going the speed it was before. I turned the car off and checked to see if anything is wrong, but nothing seem to be out of place, all the oils and fluids are in the right amount. Once I turn the car back on, there's this straining sound "like a conveyor belt moving too fast" occur every time. After I restarted the car, it seem like the problem solved itself, however, after about 1-2 minutes on drive, the problem happen again and forced the car into a neutral gear.

I checked around and people said on both forums and in person that it might be the ECU or the transmission itself. Is there any way that you guys can let me know what could be the problem and where is the location of the ECU on a 2007 RAV4? I looked everywhere and cannot seem to find it.

Thanks so much in advance.
 

·
Registered
Joined
·
2,494 Posts
Hi guys, I'm new to the forum. I own a 2007 Toyota RAV4 4 cylinder automatic transmission. Recently, I was driving and the car's gear shift just stopped working. The engine still revs up just fine but the car doesn't accelerate at all and just going the speed it was before. I turned the car off and checked to see if anything is wrong, but nothing seem to be out of place, all the oils and fluids are in the right amount. Once I turn the car back on, there's this straining sound "like a conveyor belt moving too fast" occur every time. After I restarted the car, it seem like the problem solved itself, however, after about 1-2 minutes on drive, the problem happen again and forced the car into a neutral gear.

I checked around and people said on both forums and in person that it might be the ECU or the transmission itself. Is there any way that you guys can let me know what could be the problem and where is the location of the ECU on a 2007 RAV4? I looked everywhere and cannot seem to find it.

Thanks so much in advance.
How is the transmission fluid level/condition? Ever been changed?
 

·
Super Moderator
Joined
·
10,127 Posts
Gee, not another one & done perchance?
 
1 - 6 of 6 Posts
Top