Toyota RAV4 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have a 2008 Toyota RAV4 with the 4 cylinder 2.4 liter engine. My issue is I have a rough idle in park and while stopped in gear there is no check engine light and no code stored so need help to figure this problem out. RPM does drop about 200 RPM when rough. Car has pretty new NGK spark plugs, so some help troubleshooting would be nice.
 

·
Registered
Joined
·
218 Posts
Throw a bottle of seafoam in your full gas tank and drive for a week to see if anything changes. Make sure you used the same plugs that were on the vehicle or use the ones you're supposed to use. Ask your dealer or check your manual.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
This is what ive done (decided to while I was at it). Exchanged the plugs as I felt I may have got a bad set, that helped alot but still a little rough. So I got some throttle body cleaner and cleaned out the throttle body really good, then since I was at it had some Mass Airflow cleaner and cleaned that sensor. I also replaced the air filter, wasnt all that bad, but eh doesnt hurt. And then I went ahead and added a can of seafoam to the gas, to give the fuel system and air system a makeover. Now the car idles a ton better , a little faster than it used to (around 900 rpm) but Im just guessing after the computer relearns everything should settle down.
 

·
Registered
Joined
·
343 Posts
Have you pulled your ignition coils? We had one go bad and the car didn't run well. I found a whole engine at the dealer for $200 with coils! That was $40 more than the parts house wanted for one, so I bought it. We have used 3 of them and have a spare motor with ~140,000 miles on it. The previous engine owner had it replaced when the oil usage notice came out even though it didn't use oil. Can't beat that! The mechanic was going to put it in his dad's rav, but his dad wrecked it before they could put it in. I found it at the right time.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Thios is the lovely 2.4 LOL. Its a nice little motor , but they are known for issues with the rings and drinking oil (mine is no exception). I would have took it in to have gotten it fixed but when I got the car, well was already past the miles to do so. Still a great motor, but thats off topic.

No what Ive done seems to have helped, even though she is idling a little high right now, at least its smoother.
 
1 - 7 of 7 Posts
Top