Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 2010 4cyl. It turns over great, but won't start. While it's turning over, it will sound like it wants to start but never does. I hooked up a good OBII Code Reader and there are no codes in the vehicle computer.


I have done a bunch of google searches and searches on the RAV4 forum site to try to find out where the fuel pump is located and for any advice from anyone who has changed one.


Thanks for any help!
 

·
Registered
Joined
·
9,024 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Blogson, thanks for the advice! Between what you said and a post by Canon101, I got the vehicle going. It was evidently flooded somehow. It's my wife's car and she said that she doesn't remember doing anything out of the ordinary.


Anyway, because of Canon101's suggestion, I put the pedal to the floor and tried to start it. Then I backed off the key to the Accessory position and then tried again to re-start. It started right up.


According to his post, if you turn the key all the way back to the Off position, the fuel pump re-sets and starts pumping again (something like that). But if you turn it back to the Accessory position, it does not start pumping until the vehicle starts.


Thank you Blogson for taking the time to offer your suggestion! What a great forum, saved me time and potentially some money.
 

·
Registered
Joined
·
1,447 Posts
How many miles are on this?...I suspect you will have further issues...if your engine floods then you have some other issue...exhaust may be plugged.. may need new plugs and air filter...when the fuel pumps first starts to run it is to pressurize the system and once the motor starts to turn over the injectors pulse and send fuel inti the engine...if it doesn't start then your air or ignition source is likely the reason...while flukes do happen I would prepare for some maintenance to be done...
 
1 - 4 of 4 Posts
Top