Toyota RAV4 Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I bought a used 2013 LE and the backup camera does not work. Of note, the car was previously involved in a rear end collision but was fixed without any long term problems. When I put the car in reverse, nothing happens on the center console. No black screen, no nothing. I took it to the dealer and they ran a "diagnostic" and determined that the problem was actually with the radio itself and would need to be replaced at ~$800. This doesn't make much sense to me since every other feature of the unit works perfectly, the car had been hit in the back of the car where the camera is located and the backup camera would seemingly be more likely to fail as it is a much smaller electronic piece with wiring throughout the whole car. But that is what they said.

Has anyone had a similar experience where the backup camera stopped working completely? If so, was the problem with the radio unit?

One more question, I am trying to buy another OEM radio unit to see if this really is the problem. Does the 2015 8" unit (part number 86140-0R130) fit in a 2013 LE (original part number 86140-0R080)? It looks like the dimensions are within 0.1 to 0.2cm of each other with the newer unit being slightly bigger.

Any and all help is greatly appreciated.
 

·
Registered
Joined
·
143 Posts
Cant help you with radio nut i personelly start simple and make sure the camera is connected prpoperly. Any chance they failed to connect when body work was performed or camera or wiring was damaged at time of accident. While their is a slight cjance im skeptical its the radio if everything properly. I would start by inspecting wiring connection and wiring, if that looks good perhaps try replacing the camera first before radio.you can pick one up on ebay for $45.

Sent from my LG-US996 using Tapatalk
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
So I have checked all the physical wiring connections and they appear to be sound. Is there a way to check the camera itself to make sure it is getting power, turning on, etc?
 

·
Registered
Joined
·
644 Posts
The camera should provide the standard analog video signal to the radio.
Oscilloscope can help or a AV device like a TV or a monitor with RCA AV input.

Check this video out:

 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
What is the part number for your 2016 radio? I just took mine out and it is 86140-0R010. It appears that this number and 86140-42010 (which I have seen online) are the same radios. Does anyone know the difference between the two radios.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
In addition, 0R080 looks the exact same too. My radio was assembled in Mexico and those other two similar radios say China so I am not sure if that is part of the difference. This seems to be important since my problem is a backup camera and there are different systems between North America and Asia (NTSC vs PAL) so I need my replacement radio to be able to accept NTSC camera input.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #9
I have no idea if that radio would be compatible with my 2013 LE. If the plug ins look the same and the dimensions are the same, I am guessing it would work. Do you have a picture of the back of the unit?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
Here is the top and back of my unit. I do not think they are compatible. A lot of the plugs appear similar but my unit doesn't have that separate piece on the bottom.
 

Attachments

·
Registered
Joined
·
644 Posts
Try to ground Parking brake pin 15.
You may simply not have the wire connected to the parking brake.
Also you are missing 24-pic connector, where the backup camera input is.
 

Attachments

·
Registered
Joined
·
548 Posts
If the problem was indeed the camera, then the radio would go to a black screen, and trying to display the rear camera signal. Since you say that there is no change when in reverse, then the radio is not being signaled into going into the reverse mode. Could be the signal paths between the transmission and the radio.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #15
Whipaway, that is a good point that I hadn't thought of. I went ahead and ordered a 2015 rav4 radio from Ebay that should come in a few weeks (from China, so we will see if it is any good).

If it is indeed a problem between the radio not communicating with the transmission that I am in reverse and it needs to find the camera, then how is that fixed?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #16
Nikolai, what exactly is required to do the grounding you are suggesting?

You say "You may simply not have the wire connected to the parking brake." But the rav4 comes standard with a backup camera, so I haven't changed any of the connections.
 

·
Registered
Joined
·
25 Posts
does any body know the color codes for the wires on pin out radio (head unit 86140-42460) wiring diagram. for 2017 rav4 xle.
 
1 - 17 of 17 Posts
Top