Toyota RAV4 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2016 RAV4 with keyless entry/push button start. The remote fob/door handle touch lock/unlock was working fine yesterday. Today, pushing the remote unlock button does nothing. Tried both keys. Tried installing new battery on key. Used the physical key to unlock the car. Started it, drove it around. Exited the vehicle, no ability to lock the doors without sticking the key into the lock cylinder. Tried walking around the vehicle clicking the remote to try and see if it was a receiver issue. Tried this with both remotes. On a push button start, I can't do the whole retraining trick for the remote like I can on my key start Toyota. Poked around, checked some fuses like ECU/B, etc. All good. The power door locks all work using the physical key or buttons inside the car. On both keys the led light is working. I even tried putting the key into battery saver mode and then out of it again. No dice. Car is barely a year old, I guess it's off to the dealer unless y'all can think of anything? Could the RKE receiver in the D-pillar have come unplugged? I really don't like going to the dealer :-(
 

·
Registered
Joined
·
242 Posts
Sounds like you’ve tried everything. Going to the dealer sucks, but that’s why you have the warranty.
Good luck
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Update

On the way home yesterday, it occurred to me that I had not tried disconnecting the vehicle battery. I popped off the positive cable for about a minute, reconnected and success! We shall see if the issue happens again, but for now I'm good.
 

·
Registered
Joined
·
185 Posts
On the way home yesterday, it occurred to me that I had not tried disconnecting the vehicle battery. I popped off the positive cable for about a minute, reconnected and success! We shall see if the issue happens again, but for now I'm good.
Any chance this occurred after a severe thunderstorm with nearby lightning?
 

·
Registered
Joined
·
342 Posts
I popped off the positive cable for about a minute, reconnected and success!
I would not be surprised if the module responsible for the keyless system is a processor running high level code.

You just did what has been the #1 step when troubleshooting computers for the last 30 years or so. :D
 

·
Registered
Joined
·
294 Posts
My 2013 had similar issues. Worked, then not. The steering computer failed; replaced. Then, while still at the dealer, the key computer had to be replaced. Both under warranty.
 

·
Registered
Joined
·
111 Posts
Update

On the way home yesterday, it occurred to me that I had not tried disconnecting the vehicle battery. I popped off the positive cable for about a minute, reconnected and success! We shall see if the issue happens again, but for now I'm good.
Disconnected battery on my Rav and the system started working again.
 
1 - 8 of 8 Posts
Top