Toyota RAV4 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
I just purchased a 2017 limited, and the yellow lines that are supposed to show the predicted steering path do not seem to be working. I can switch my camera guidelines into that mode. 2 blue curved lines show up, but they do not sway with the steering angle. I don't see anything in the manual or in the options that allow me to enable this - what gives? Anyone else ever experience this issue before?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
I did search, and that thread did come up. I followed all of the settings prompts listed there, but nowhere did I see the option to turn on the dynamic grid lines on my vehicle. Thank you for the link, though.
 

·
Premium Member
Joined
·
7,936 Posts
The ignition has to be on when setting the steering guide line option, it won't show in the accessory position, may even have to be in reverse, I don't remember. If it still doesn't show that option see your service dept, the dynamic steering guide lines are standard on all '16> models AFAIK.
 

·
Registered
Joined
·
63 Posts
Did you follow the steps that I laid out in that thread?

Step 1: Enter the diagnostic menu for the display system. You do this by turning on the vehicle (but do not start the engine) So either turn the key to the first notch or just press the Power On button and not stepping on the brake (if you have push button start). Hold the "Audio" button on your the main console, then turn the light on/off 3 times. You should hear a distinctive beep, that means you've activated diagnostic mode, let go of the audio button. And the menu should appear.

Step 2: After you've entered the menu, you can then see the settings on the screen. "Camera Setting" will be grayed out. You should now proceed to start the engine (and it should no longer be grayed out)

Step 3: Select "Steering Angle Setting"

There will be two buttons on the screen "Steering Center Memorize" and "Max Steering Angle Memorize"

Step 4: Make sure the steering wheel is in the straight ahead position, and press "Steering Center Memorize"

Step 5: Turn the steering wheel all the way to the left and press "Max Steering Angle Memorize"

Step 6: Turn the steering wheel all the way to the right and press "Max Steering Angle Memorize"

The system should then "Beep" and return you to the previous menu

Turn off the vehicle and the next time you start it, it should no longer be in diagnostic mode.

Make sure to select the first option in the Vehicle: "Back Camera Guide Line Settting" in the "Vehicle Settings" portion of the standard menus


Try that and see if it fixes the issue. I experienced the same problem with mine and this resolved it. It's been working perfectly for over a year now.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #6
Did you follow the steps that I laid out in that thread?

Step 1: Enter the diagnostic menu for the display system. You do this by turning on the vehicle (but do not start the engine) So either turn the key to the first notch or just press the Power On button and not stepping on the brake (if you have push button start). Hold the "Audio" button on your the main console, then turn the light on/off 3 times. You should hear a distinctive beep, that means you've activated diagnostic mode, let go of the audio button. And the menu should appear.

Step 2: After you've entered the menu, you can then see the settings on the screen. "Camera Setting" will be grayed out. You should now proceed to start the engine (and it should no longer be grayed out)

Step 3: Select "Steering Angle Setting"

There will be two buttons on the screen "Steering Center Memorize" and "Max Steering Angle Memorize"

Step 4: Make sure the steering wheel is in the straight ahead position, and press "Steering Center Memorize"

Step 5: Turn the steering wheel all the way to the left and press "Max Steering Angle Memorize"

Step 6: Turn the steering wheel all the way to the right and press "Max Steering Angle Memorize"

The system should then "Beep" and return you to the previous menu

Turn off the vehicle and the next time you start it, it should no longer be in diagnostic mode.

Make sure to select the first option in the Vehicle: "Back Camera Guide Line Settting" in the "Vehicle Settings" portion of the standard menus


Try that and see if it fixes the issue. I experienced the same problem with mine and this resolved it. It's been working perfectly for over a year now.

I had previously followed your directions, but every time I started the car to make the camera button "un grayed" it would restart the head unit and kick me out of the diagnostic menu. I just tried entering the diag menu with the car running, and I was still able to get into it. Got into the camera settings this time, calibrated the steering, heard the loud beep, restarted the car, and voila! The dynamic grid lines are now working. Thank you!
 

·
Premium Member
Joined
·
1,427 Posts
Did you follow the steps that I laid out in that thread?
I have not tried this on my wife's '15 XLE, but I tried my '16 Corolla S-Premium (full Nav with app suite and XM) and that option was not available when I put the HU into diagnostic mode.

The only option related to the steering was confirmation of the position of the buttons/knobs.
My BU display has the blue box but no curving yellow lines.
 

·
Premium Member
Joined
·
7,936 Posts
I think it's because it's not available on the hybrids.

It indeed is standard on the Limited HV, been using it for 2yrs, should be available on the XLE HV as well in the convenience package IIRC.
 
1 - 9 of 9 Posts
Top