Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hello and thank you for this great forum, I have found a lot of useful information here.

I recently acquired a 1996 5MT 4WD 2 door with about 220k miles. I replaced water pump, timing belt, valve cover gasket, spark plugs and spark plug wires. (I used OEM parts)

I fired the car up and it ran great, with the exception of sometimes idling around 2000 RPM and displaying the check engine light. The code it was displaying was P0336.

I took the timing covers off the motor again to check my timing belt. It appears to be correctly timed (crankshaft pulley and cam pulley are at TDC) but when I fire it up it revs all the way up to about 3900. No check engine light.

I've looked over all my vacuum connections. I did notice looking at the parts diagrams that 1996 is the only year with a distributor, but I haven't touched that aside from replacing the spark plug wires.

Thank you so much for any ideas you may have
 

·
Premium Member
1999 Toyota RAV4 with 3MZ-FE 6 cylinder engine, camo wrap, OME lift, heavily modded
Joined
·
2,045 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Thanks much for the rapid reply.

Crankshaft sensor is installed and wired up. Crankshaft pulley looks good with no missing teeth or other visual defects.

Real defect here is ME, for not realizing my throttle cable was stuck open and causing the high RPM idle. {BAKA}

Thanks again
 

·
Super Moderator
Joined
·
10,135 Posts
Real defect here is ME, for not realizing my throttle cable was stuck open and causing the high RPM idle.
Yeah, that'll definitely do it! Welcome, enjoy your RAV4 and thanks for admitting your mistake. :wink
Reminds me of what one member listed in his signature line, "Car stock, driver modified!"
 
1 - 4 of 4 Posts
Top