Toyota RAV4 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
This isn't my daily driver. So for about a month or so when I would first start it. It would run fine and start fine. Untill I would touch the gas. Then it would stutter and I would have to feather the gas( my 5 seconds) untill it ran strong. Then I wouldn't have a problem. Then one day it just started runnin like crap. Stuttering real bad untill about 2000 rpm then it was good but every time the rpm's dropped it would stutter and act like it wanted to die. Then one day it started I gave it gas it stuttered and died. Then never started again. I have changed the fuelpump and sparkplugs. I'm at a loss on what it could be.
Thanks in advance
 

·
Registered
Joined
·
432 Posts
Could be any one of a number of things, did you have a reason to change the fuel pump, did you change the fuel filter as well, do you have a CEL or any codes, are you OBD I or II (where are you?)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Right now I live in germany. I changed the the fuel pump because I have had other vehicles do similar things and it was the fuel pump. I did not change the fuel filter. But pulled the line to see if when I cranked it over fuel would still flow it did. Don't have a code reader.
 

·
Registered
Joined
·
432 Posts
Yours may be OBD1, if so when you look under the hood there should be a black plastic box with Disgnostics written on the top, it's adjacent to the power steering reservoir, if so then you don't need a code reader.
Either search on here or google how to read codes with OBD1 and it will explain how to jump two terminals, I forget offhand which, E1 and TE1 maybe but check......then you can read the flashes of the CEL on the dash, then google what the codes are for, it's easy to do and with any luck you'll find out what's wrong, let us know how you get on.
If there's no Diagnostic port then you have OBD11 and you'll need a reader.
 
1 - 8 of 8 Posts
Top