Toyota RAV4 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
A little background. My 98 RAV4 has 334k on the odometer, I drive about 5-6k a month on average with it until recently. Long story short, busted my axle and got that replaced. Battery was low after sitting at the repair shop for a week, jump start and brought it home. Discovered a crack in my tire so I let her sit for about a month. Make an apointment, the morning of I go to jump start it and have no luck.

With my Grand Cherokee hooked up it would crank but not turn over and fire up like the last time. The door locks did not work (automatic), radio did not turn on, dash cluster did not show any lights either. Do some careful inspection and discover the Alternator 100A fuse was blown, replace that. The other two looked fine.

Now the door locks work and the gauge cluster lights up like normal again, but the radio does not work and it doesn't fire up still so I have made progress. At this point I am somewhat stumped, especially since Toyota is not something I am overly familiar with. I do not believe I can hear the fuel pump kick in so I am left wondering if there is another fuse or relay hidden somewhere that I am not aware of?

I remember with my old Honda on hot days the fuel relay right under the dash needed to be replaced, but this is different. The RAV had no hard starts or anything odd when we jumped it to bring it home.

All ideas and input is welcome, need to get my daily back on the road again, especially since neighbors are starting to complain about it sitting on the street.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Update

Had somehow overlooked the EFI fuse which was also blown, replaced it and fired right up.

Back in business.
 
1 - 2 of 2 Posts
Top