Toyota RAV4 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
First time post, but have owned 3 Rav4's (currently own a 97 and 98) and have run into an issue I can't figure out.

My current 98 ran perfectly until recently. Due to some unexpected travel for a family issue, my car sat in my driveway for roughly a month. When I returned home, I was able to start and drive our 97 without issue. When I turned the key in the 98, there was a sudden/brief loud metallic grinding sound, and then the car started, and then quickly died. Turned the key again, same thing. 3rd time the car started without issue, and I warmed it up, drove it a bit, and it was fine for about 2 weeks.

After roughly 2 weeks of daily driving, I started to notice an intermittent issue where when I'd turn the key, and there would be no sound. No clicking, but the lights would come on the dash, and then after a couple seconds of silence, the car would start. Over the course of a couple weeks, the problem got progressively worse, until last Sunday the car stranded me while I was out running errands. Simply wouldn't start. The car had power (battery), but just wouldn't turn over. I had it towed, and the mechanic that I go to for pretty much everything said the starter was bad. I had it replaced, and was back on the road.

Over the course of this past week, the issue has returned. Turn the key...nothing happens...and then after a couple seconds, the car will start. Last night, the problem was so bad, I thought I was again going to be stranded, but after repeated attempts, the car finally started. This morning though, it wouldn't start at all. I had it towed back to the mechanic, and of course it started right away for him without issue. He's checking it now, thinks it "might be the ignition switch."

My concern here is that I've read a few other threads with people having similar issues, and very few of them seem to have ever figured out the issue (or never reported back)...or the solution seemed to be 1 of about 5 different possibilities. Has anyone ever chased down what the actual problem might be without spending several hundred dollars doing it? Because I'd love to avoid that...

Thanks for your time and input.

J
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
So the first shop I took it to gave up. Took it to a second shop, and they figured out that the neutral safety switch was failing. The mechanic told me attached wires and lights from the input to the switch from the starter relay and from the output of the switch to the starter, so when power was traveling as it was supposed to through the neutral switch, both lights would light. When it didn't crank over with the key turned, the output light didn't light, which proved the relay was working but the neutral safety switch was failing. It wasn't cheap to figure out and fix...but it's good now and starts perfectly every time.
 
1 - 3 of 3 Posts
Top