Toyota RAV4 Forums banner

1 - 4 of 4 Posts
V

·
Guest
Joined
·
0 Posts
Discussion Starter #1
When I turn on my ac the switch indicator show that it is on but the compresor clutch does not go on. Checked all fuses and they are ok.
Pull the wire from the compresor and when I turn the ac switch on there is no power going thru that harnes to turn on the compresor clutch.
Anyone can help ?
Need wiring diagram to solve this problem.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #2
vojtecki said:
When I turn on my ac the switch indicator show that it is on but the compresor clutch does not go on. Checked all fuses and they are ok.
Pull the wire from the compresor and when I turn the ac switch on there is no power going thru that harnes to turn on the compresor clutch.
Anyone can help ?
Need wiring diagram to solve this problem.
I'd get yourself a $15 Chilton or Hayes manual, it can help you out with this. Or better yet, check out Ebay for an official Toyota manual. They tend to pop up ther once in awile.
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Have you checked a fuse called CDS in the main fuse box ... a hefty thing if I remember - one of those big square ones - about 40Amp
 

·
Registered
Joined
·
106 Posts
Maybe apples to oranges but my Altimas' compressor was not kicking on and as it turns out it will not kick on if the R134a is either too low or completely drained. I went to my local autoparts store, picked up a recharge kit and went at it. I now have that frosty sensation in my cabin.

Below is a picture of the guage on the "L" low pressure line of my system.

 
1 - 4 of 4 Posts
Top