Toyota RAV4 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 2005 RAV suddenly started to have ABS/VCS/TRAC/BREAK light on, sometimes few minutes after driving sometimes right on start up. At the same time I started to notice fan stop working and then starting again.

Took it to Toyota, to do test. For the fan they said they could not test unless it’s not working at all.

They run ABS/VSC/TRAC and came up with codes:
C0226,C0236,C0246,C0256,C0273,C0278,C1223, C1241
And said I need to replace whole ABS actuator assembly, with around $3K price tag.

On the way home I’ve noticed, that 3 light ABS/VSC/TRAC/BREAK came up exactly at the moment when FAN stopped ( fan started later again and turnoff/on few times).

Later I read similar light issue can be electrical/related to alternator issues. Curiously code C1241 is abnormal low or High Voltage.

So I did little experiment, I turned fan off, and drove for 30 minutes, light never came up.
I soon as I turned fan ON, and switched to D the same issue happened, fan went off and ABS/VSC/TRAC/BREAK went on right away.
Just to mention AC was not enabled in either case, just the FAN.

Going to test longer drive to and from work tomorrow without FAN to see if issue never happens for sure, but it was very repeatable.

What should I do? Ask Toyota dealer to replace FAN or might some other issue related to the fan? I've read there are two fans...

Other idea that maybe power something in ~60W range from internal power to see if it is causing the same effect. Measuring voltage on cigarette light adapter when it happens doesn’t show an issue (13.6-14V) , but perhaps I need some mode that shows maximum voltage freeze or something like that?

Thanks!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2 (Edited)
SOLVED: ABS/VCS/TRAC/BREAK, code C1241 and FAN Edit Post

update. one of the cable plugs in battery + junction box was loose.
Seems like it was momentary loosing connection on increased power draw.
replugged it , thou it doesn't seem to lock from what I could see.

Anyway, both ABS/VSC/TRAC/BREAK lights are gone, fan is not stopping anymore.
Zero cost!

I wrote small logger to record voltage during drive 10 per second with the lowest and the highest readout, and it stays within 12V-13.9 on my drives so far.
 
1 - 2 of 2 Posts
Top