Toyota RAV4 Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
Has anyone had to change the Accelerator pedal Position Sensor. I keep getting a trouble code P2121. The car goes into limp home mode but if you turn it off and then on again it accelerates fine but the lights stay on, CEL TRAC OFF and 4WD. Mechanic has already cleaned the throttle body. My research indicates that if cleaning the Throttle body doesn't work it could be the APP sensor. Since the part is some what cheap, $117, I would take a shot and have it changed. Has anyone had this done or did it themselves. If it is an easy switch I would like to try it my self. Any advice would be great. I know it in the gas pedal but that's about it. Searched the forum but no results came up.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,722 Posts

·
Registered
Joined
·
731 Posts
I don't believe in the shotgun approach unless you are made of money and have nothing to do.

Your mechanic should have a scanner that will graph the accelerator pedal position sensors.

The APP sensor has 2 sensor circuits: main and sub.

If either circuit malfunctions, the ECM controls the engine using the other circuit.

If both circuits malfunction, the ECM regards the accelerator pedal as being released. As a result, the throttle valve is closed and the engine idles.

Try graphing the main and sub sensor and look for a dropout.
 

·
Registered
Joined
·
3,698 Posts
There were some that replaced their pedal with a different part number which had a better design.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,722 Posts
There were some that replaced their pedal with a different part number which had a better design.
True, but since he has a 2012, he probably already has the newest design.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #6
Hi Junebug,
So just change the entire pedal assembly. The part you listed has the sensor in it allready? I looked at it and it seems to but i wasent sure. That"s much better than changing the sensor. Here in New York the sensor by it self was $117. Pedal looks easy to replace. Just Two Bolts and the wire harness.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,722 Posts
Hi Junebug,
So just change the entire pedal assembly. The part you listed has the sensor in it already? I looked at it and it seems to but i wasn't sure. That"s much better than changing the sensor. Here in New York the sensor by it self was $117. Pedal looks easy to replace. Just Two Bolts and the wire harness.
Yep, just 2 bolts and it plugs right in.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,722 Posts
Thanks Junebug. Any opinion as to weather it will solve the issue.
Well, that code is very specific. If it's not that sensor, then it would have to be the wiring or the connector. Why not try unplugging and re-plugging that accelerator connector a few times? A little corrosion on the ground wire is all it would take to prevent it from working.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #10
Turns out the part that you listed is no longer manufactured so going to have the local mechanic change the sensor and see what happens. Thank for the help.
 

·
Registered
Joined
·
24 Posts
I am having the same problem P2121. Intermittent loss of throttle. Sometimes I can still driver it and other times total loss of throttle (dead throttle). I can pull the EFI fuses or remove disconnect battery for short time and it will reset. Been having problem for 6 months. At first I could reset it and it would be fine for months. It has been happening more lately and will trigger now if I tap the throttle peddle several times in a row.

Been thinking of buying a use foot throttle to see if it solves the problem.
 
1 - 11 of 11 Posts
Top