Toyota RAV4 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi everyone,

Just joined this site to get familiar with a 2008 RAV4 that I will be fixing up to give to my brother and fiancee. The car has about 161K miles and was previously owned by my brother-in-law. He knows nothing about cars and upkeep (for example he put windshield washer fluid in the brake reservoir of my wife's car.)

I took it to the dealer yesterday to have 7 recalls fixed, which they happily obliged. I also paid for an oil change and brake fluid flush, since I figured why not give the the tech some paying work as well.

I got it back today and along with the long list of repairs that I was recommended. It VIOLENTLY shakes now at idle and gets worse when in gear. They said the air filter was plugged up, but I haven't looked at it yet. However, prior to bringing it in did not shake like this at all. I was told it's in a relearn process.

I plan on doing the inner/outer tie rods, shocks, air/cabin filter, coolant, brakes, PCV, plugs, and valve cover gasket.

I'm not familiar with Toyota's, but I do work on my; Infiniti, Audi, and Subaru prior to selling it.

Is there anything else I should look at? ATF, front/center/, and/or rear diff.
 

·
Registered
Joined
·
8,529 Posts
Which engine - I4 or V6? Knowing that could help forum gurus in resolving the problems.
 

·
Registered
Joined
·
3,691 Posts
The car should not shake since you said it didn't before you took it in. Sounds like a vacuum hose maybe disconnected or something? Look at all the vacuum hoses carefully for anything not connected. Something tells me the dealer wants to rip you off.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
That's what I thought and I checked all the hoses. There is no CEL and doesn't seem to hesitate or have any performance issues once I hit the gas. I called the dealer and they said to bring it back in and that it shouldn't be doing that either. I'll have to drop it off in a few days though.

One other thing I noticed is that around 1500-2000 RPM it does this kind of weird noise that I can't explain that goes away when I go faster. Also, in the rear I'll hear sort of like a grinding noise for a few seconds. I'm not familiar with 4x4's would this just be something engaging?
 
1 - 5 of 5 Posts
Top