Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
337 Posts
Discussion Starter #1
Hey folks.

About 3 days ago I could hear a sort of whiny/groaning sound coming from under the hood like something is straining.

Today the battery warning light AND the parking brake light came on at the same time. After parking and trying to restart it's dead.

Also my stereo would turn off and on a few minutes before this happened.

I'm guessing this is my alternator that needs replacing?

I will head out in a few hours and check voltage on battery.

If I replace the alternator should I do the belt as well?

Thanks for any tips
 

·
Registered
Joined
·
3,692 Posts
You need to make sure you test the battery. Take the battery to Can Tire to have the battery check. They do it free over the counter.

If the battery is ok check the alternator. There are many youtube video on that.

If you need a new alternator Rockauto has some good prices if you are in no hurry.

As for the belt that can be done at the same time if you want. Rockauto is a good place for belts. I have done the belt and is not bad.

Can Tire is not the place to buy alternators. Brands such as Remy and Denso are preferred choices. Reman alternator can be a hit or miss.
 

·
Registered
Joined
·
8,529 Posts
Strongly suspect the alternator, from the symptoms which were described. Some auto parts stores (at least in the U.S.) will check the alternator for free. There is no point in checking the battery voltage unless it has been fully charged and allowed to sit for a couple of hours, then it should be at least 12.7, and it should also be capacity checked - again some parts stores may do this for free as well. From your description the battery is discharged.
 

·
Registered
Joined
·
337 Posts
Discussion Starter #4
Thanks guys. I did do the battery test at Can Tire (free) and battery is ok so I will get a new alternator and belt tomorrow. Fingers crossed it's simply the alternator.

I bought a new battery today because I wanted a spare and car cranked over no problem and drove it home on battery power so I suspect it's simply a bad alternator. I wouldn't be very happy spinning around for 280,000km 13 years either.

Thanks again.
 
1 - 4 of 4 Posts
Top