Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
Driving along, doing 30mph - look down at the speedometer gauge - its not even moving! Even in start/stop traffic its not moving. Next day - everything is back to normal. Of course the dealer mechanics can find no fault, as everything is working perfectly during their tests.

All i can do is wait for it to happen again and hope im not doing high speeds should it go funny.
 

·
Registered
Joined
·
986 Posts
Had the same problem with my Volkswagen a few years back. Never fixed it or found out what was causing the problem. I think it was caused by all those neutral drops I used to do with the automatic transmission.

On our Ravs, just like all modern cars, the speedometer is electronic instead of mechanical. It uses a speed sensor located on the top of the transmission which measures the rotational speed of a gear in the transmission, either magnetically or optically. Anyway, the speed sensor is connected to the engine computer and the speedometer by wires with connectors. If any of these wires comes loose, the speedometer will not work. The engine computer may or may not trigger the CEL depending on which connection is not working.

There are three main causes for the speedometer to not work:
1. speed sensor in the transmission is bad
2. loose connector or broken wire
3. water in the connectors or a short in the wire.

Not the easiest problem to diagnose.....
 

·
Registered
Joined
·
99 Posts
Discussion Starter #3
ah i see.
Im guessing it may have been a loose wire connector/bad contact or something, as its not shown itself since and may not re-occur, now that the mechanics have jiggled about with things.

thanks
 
J

·
Guest
Joined
·
0 Posts
My 2001 5 speed Rav 4 would experience a few hours of no speedometer after manually washing the car. It would always go away until now. My odometer is not working now either. Is this a short in the circuit? How much will the dealer ask me to fix this?
 
1 - 4 of 4 Posts
Top