Toyota RAV4 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Was driving my 2012 RAV4 2.5L FWD today on the highway and the red Auto LSD light started to flash on and the check engine light came on too. Doesn't seem to be anything wrong with how it drives, but the lights don't go off. Turned the traction control on and off several times, but didn't do anything.

Thoughts on what is wrong and any way to fix without taking to dealer?
 

·
Registered
Joined
·
2,488 Posts
Was driving my 2012 RAV4 2.5L FWD today on the highway and the red Auto LSD light started to flash on and the check engine light came on too. Doesn't seem to be anything wrong with how it drives, but the lights don't go off. Turned the traction control on and off several times, but didn't do anything.

Thoughts on what is wrong and any way to fix without taking to dealer?
While not necessary to go to a dealer, you will have to take it somewhere to have the codes read and then it can be determined what needs to be done.
 

·
Registered
Joined
·
43 Posts
Try the paperclip trick from the dash light thread in the mechanical forum? Your lights don't totally match the most common descriptions but you might be able to figure something out
 

·
Registered
Joined
·
1,447 Posts
Paper clip trick is old school LOL....go to an auto parts store and ask them to read your codes....most of them do it for free and will give you a printout of the reading....
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,639 Posts
Paper clip trick is old school LOL....go to an auto parts store and ask them to read your codes....most of them do it for free and will give you a printout of the reading....
Paper clip trick may be old school but it can read ABS, traction control, and auto LSD codes from the anti-skid computer. Your code reader at the auto parts store can only read engine codes. LOL
 

·
Registered
Joined
·
3 Posts
Any idea on what this might be? The same lights just came on my wife's 2011 Rav. I hear a buzzing noise from under the hood when the key is in "run" before cranking the engine.
 

·
Registered
Joined
·
3 Posts
Any idea on what this might be? The same lights just came on my wife's 2011 Rav. I hear a buzzing noise from under the hood when the key is in "run" before cranking the engine.
Turns out the DTC from Auto Zone was P0171- System too lean. Took it to Dealership as the car is under extended warranty, and they diagnosed the problem as a purge valve stuck open. My guess is that since the purge valve was stuck open the engine was sucking in air thus causing the lean code.
 

·
Registered
Joined
·
97 Posts
Thats happened to me a month ago, i use my Techstream to check find that there are two misfires in cylinders 2 and 4 , i did a clan the error in the techstream software and they gone out.
 

·
Registered
Joined
·
5 Posts
I have a same going on right now. Got my it figured with my OBD code reader, showing code 0138 which is O2 sensor. Apparently ECU figures that there is malfunction in the engine monitoring and cutting off LSD, which causing the flashing warning light. So, I am going to check o2 sensor first.
 

·
Registered
Joined
·
4 Posts
Hiwd
I have a same going on right now. Got my it figured with my OBD code reader, showing code 0138 which is O2 sensor. Apparently ECU figures that there is malfunction in the engine monitoring and cutting off LSD, which causing the flashing warning light. So, I am going to check o2 sensor first.
How'd this go? Thx
 

·
Registered
Joined
·
1 Posts
I know this is an old post but wanted to add this information for possible future issues that someone may have.....My daughters 2012 had this issue, blinking Auto LSD with CEL. This occurred very soon after an oil change so I was suspicious that the crew at the quick change maybe fooled around with something. I found a hose pulled out of the air flow pipe near the mass flow sensor. I know they pulled the cover to check on the air filter and this is probably when the hose pulled out so I will give them the benefit of the doubt that they did not do this on purpose. Anyway I pulled the negative cable on the battery to reset the lights and the problem went away and has not returned.
 
1 - 12 of 12 Posts
Top