Toyota RAV4 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, I have a 2009 Toyota RAV4 that I purchased not too long ago (about two years) from a dealership. It recently was having issues starting. I checked to see what my OBD2 scanner could bring up, and it gave me a single code for B2799 - "Engine Immobilizer Malfunction". This seems likely since the fuel pump will not prime when turning the key, and it will not start. I have two keys, but both of their remote starts have stopped working. The battery is brand new (not sure if that matters). I searched on these forums and it seems that a few other people have had similar problems, but I have not seen a solution. Is this something I can fix myself, or should I search for professional repair? Thanks.
 

·
Registered
Joined
·
1,483 Posts
Sounds like you have an aftermarket remote start system that now failed.

Do you have Techstream? That might provide more information.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Sounds like you have an aftermarket remote start system that now failed.

Do you have Techstream? That might provide more information.
Hey, thanks for your response. I unfortunately don't, and although I'd like to know why this is happening, I haven't had much time to wait. I towed the car to a private mechanic. If this doesn't work out I might have to take it to a Toyota dealership. My best guess is that the key's battery has died and the car won't turn itself on due to the encoding. I will try to add further updates if I know anything else.
 
1 - 3 of 3 Posts
Top