Toyota RAV4 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Recently bought a 2001 rav4... Checked the "stop" fuse..it's good...checked both bulbs..they're also good...not sure where to check next?....side not the cruise control light blinks but won't engage and hold the speed? Not sure if they are related ...all other electronics work fine...any help would be great

Thanks
 

·
Registered
Joined
·
3,688 Posts
The bulb can be bad even if they look ok. If you touch it with your finger it leaves an oil film which overheats and shortens the life of the bulb. Never touch the bulb without gloves. It is a common mistake most people don't realize. I suggest buying new bulbs.
 

·
Super Moderator
Joined
·
10,125 Posts
The blinking cruise control light blinking indicates a malfunction in that system. It could be caused by a faulty brake light switch since it uses that to cancel cruise. So both failures point to the same area - the switch or possible the fuse. Like light bulbs bad fuses can also look good. Test by swapping with another.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I tried a fresh fuse no dice...I'm thinking brake switch also..Cuzz both brake lights and thirds brake light up high are all out ...and cc....easy to replace the switch and its $25...I'll return it if it's not the switch...keep you posted Thx for the Quik replys !
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Ok , new switch...still no brake lights or cruise control.....Aby ideas of next to troubleshoot? Gotta have brake lights .....Thx
 

·
Super Moderator
Joined
·
10,125 Posts
Time to get out the schematics and do some signal tracing. If you're anywhere near Rickl or me, stop by. It's fun for us. Otherwise it's off to a shop that specializes in electrical repairs.

Things to check first: Does the switch click when you move the brake pedal? Are any of the wires near the connector damaged?
 

·
Registered
Joined
·
1,912 Posts
So the challenge has been issued!

The brake light switch you replaced should have 4 wires connected to it.

Pin #1 Green/White
Pin #2 Red/White
Pin #3 Green/Black
Pin #4 Either Red/Yellow or possibly White

1) Use a voltmeter and measure the voltage on the Red/White wire. It should measure 12volts whether the ignition is on or off.

2) If you don't read 12v then check the fuse again. Sometimes the labels in the fuse panel make it confusing as to which fuse is which. You are looking for a 10A fuse labelled "STOP". It should be red in color.

3) If you do read 12volts, then connect this red/white wire to the green/white wire ( use a short wire or paper clip to do this). Your brake lights should come on.

If the lights come on in step #3, your new switch is still defective, or it is not mounted correctly, and as a result it is not operating when you step on the pedal. Try operating the switch with your finger to test that possibility. You could also remove the wiring harness from the switch, and place your ohmmeter probes into the switches connector on pins #1 and #2. The resistance should read 0 ohms when you step on the pedal.

Let us know the results.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
I'm in scottsdale az .... Thanks for all the great info guys.. I definitely have been testing the right fuseI don't need to worry about a relay?I will test all your recommendations and let you know what I find out thanks a lot guys
 

·
Registered
Joined
·
1,912 Posts
I definitely have been testing the right fuseI don't need to worry about a relay?
There are no relays involved. Although the switch has 4 wires, it is obvious that the problem can be diagnosed by concentrating only on the 2 wires I mentioned. How did you test the fuse?. Visual observation of fuses is fairly unreliable. You need to check the fuse with an ohmmeter, or by measuring the voltage on the red/white wire in the connector that attaches to the switch.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
Yep visual on the fuses..the second fuse came from the spare fuse section...I'll follow the instructions to a tee once wife gets home w it from work...Thx again
 

·
Super Moderator
Joined
·
10,125 Posts
Option 2: Fly me to AZ! :wink
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
Sorry for the delay...was just new bulbs and back in action..previous owner jammed wrong bulbs in...in a side note the cruise still won't engage...light goes on then blinks but no cc ...
 
1 - 13 of 13 Posts
Top