Toyota RAV4 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
I been having trouble with my catalytic monitor not going to "ready" for my smog check. I have performed alot of drive cycles but it still wont send the ready signal. The mechanic said if it didnt get above 200 degrees the monitor wont perform the test and wont send the signal or the bottom o2 sensor was bad.

I check my coolant temp in normal operating and it stays around 185-190.
Can that or my o2 sensor be bad?

ive driven the car for 600 miles highway and street
 

·
Registered
Joined
·
159 Posts
He is wrong about 200 degrees. Rav4 has 180* thermostat, so it rarely gets above 190*. It takes a certain number of "driving cycles" (50*-180*-50* over and over again). So for instance, driving on the highway for 600 miles in one shot will not work. He probably meant "operating temperature", which is around 200 degrees.


Are you certain that you NEVER reset the codes during those 600 miles? Have you lost power in the battery and had to jump start the car?
 

·
Registered
Joined
·
13 Posts
http://www.toyotapart.com/READINESS_MONITOR_DRIVE_PATTERNS_T-EG02-003.pdf

It doesn't copy & paste well, but I think you need page 13 for a California rav4, the driving requirements are a bit longer than the Federal models.

"Drive the vehicle at 40 – 55 mph (64 – 88 km/h) for the time described below:
a. If IAT (Intake Air) was less than 50F (10C) when the engine was started, drive for 7 minutes. If IAT (Intake Air) was greater than 50F (10C) when the engine was started, drive for 3 minutes.
b. Drive the vehicle allowing speed to fluctuate between 35 – 45 mph (56 – 72 km/h) for about 16 minutes"
 

·
Super Moderator
Joined
·
10,209 Posts
Are you certain that you NEVER reset the codes during those 600 miles? Have you lost power in the battery and had to jump start the car?
Yep, either of these = start over.
 
1 - 6 of 6 Posts
Top