Toyota RAV4 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hey guys I need some suggestions or input, after having my rear passenger side tire patched driving home I noticed that the CEL, TRACTION icon and VSC lit up, went to the forums and read about ABS Speed Sensor but upon checking the cable visually everything looks good and the lights were still on so had my friends OBD2 Scan got the code P0766 - (Shift Solenoid 'D' Performance or Stuck Off).
I guess it has nothing to do with the guy removing the tire and messed up my abs sensor.

I never had experienced transmission problems before so we decided to erase the code and drove off. The next day going to work all gears shifted fine but on the way home it stayed on 3rd gear then all 3 lights came on again, borrowed a scanner erased the code, all gears work until later after driving about 15 miles lights are back and it stays on 3rd it won't go up to 4th and it down shifts fine so I decided to go to a transmission shop and the guy pulled the code, the same code p0766, he erased it and told me to have my ECU reprogrammed at Toyota. I had flushed the fluid using the cooling method and dropped the pan changed the filter 4 months ago and had driven almost 4k miles. Car has 170k miles now. 2.4L 4x2.
I checked the TSB about ECU Flash but my odometer is over 80k so hey won't do it for free. Should I buy a used ECU on EBay or just have Toyota handle it? I'm hesitant to have my solenoid D replaced if the ECU is the problem. What do you guys think?
Thanks!
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,922 Posts
This is what the Toyota service manual says:

P0766 Detected: Shift Solenoid "D" Performance (Shift Solenoid Valve S4)

Possible causes:

- Shift solenoid valve S4 remains open or closed
- Valve body is blocked
- Shift solenoid valve S4
- Automatic transaxle (clutch, brake, gear,etc.)
- ECM
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
Problem fixed after changing the solenoid S4 (part#35230-33030) $240, I also changed the transmission filter back to OEM screen mesh, the filter I bought at autozone was made of felt paper like material and it looked liked it was slowing the flow.
 

Attachments

·
Registered
Joined
·
4 Posts
Problem fixed after changing the solenoid S4 (part#35230-33030) $240, I also changed the transmission filter back to OEM screen mesh, the filter I bought at autozone was made of felt paper like material and it looked liked it was slowing the flow.
Sorry for bumping this old thread. But I have a similar problem and would like to know if I will be able to replace the S4 solenoid without removing the valve body? Will there be enough clearance from the transmission casing to pull it out and insert the new one? Did you use any guides during the replacement. Any additional info/gotchas would be highly appreciated!

Thanks in advance
 
1 - 5 of 5 Posts
Top