Toyota RAV4 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
We love our 2012 Rav4, AWD, 6 cyl. It has been flawless, now with 65,000 miles, most of that driven in Baja, Mexico.

We have a small problem with the cruise control. It sometimes pauses, sometimes surges to a speed a bit faster than the speed it is set at. This happens most often when under load, climbing hills... but sometimes also on the flats.

Is there a way to update the software, or reset to original settings, or adjust? If so, I would appreciate any reference to where I can get a YouTube video, or instructions... we are 700 miles south of the border, nothing is easy here.
 

·
Registered
Joined
·
158 Posts
It is normal for the cruise control to surge above the set speed when climbing hills or under load. It is trying to maintain the speed and usually overshoots but will come back down. It happens all the time with mine and any other vehicle I have driven. The flats occurs as well, usually if there is a head wind or even a slight incline (but looks flat). I doubt there is any way to update/adjust the settings.

I wouldn't worry about it at all.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Thanks JFeld, but it just started doing this... it is a new thing... I'm not a mechanic, but something has changed.
 

·
Registered
Joined
·
158 Posts
Hmmm...was any work done to the car right before you noticed it? Oil change even? Maybe start with checking the engine air filter and hopefully some others will chime in with other ideas as well. That is kind of odd that it just started happening. I would agree something seems to have changed
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
YES! Clever thinking... oil change and air filter just before it started happening... never even occurred to me. How would you proceed to look at these?
 

·
Registered
Joined
·
158 Posts
I would think the oil change may not affect that as much as the air filter. Still, check the oil level is ok and that the filter it tightened/not leaking. (was the filter changed as well?)

The air filter, do you know what brand/type it was changed with and if it was installed correctly? Maybe the housing didn't get latched or closed properly.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
I will check and test air filter later today. The oil filter was changed... no temperature changes, oil is full and clean.
 

·
Registered
Joined
·
8,534 Posts
My V6 RAV has always exhibited mild surge when reaching the top of a grade when using cruse control but quickly resumes the originally set speed.
 

·
Super Moderator
Joined
·
11,107 Posts
Other than the fact this just started happening I see nothing unusual here. I will say that driving the same highway that I have many times 89 octane reduced the amount of downshifting, torque converter unlocking, speed up, etc. while in cruise. Is it worth the extra $$$ at the pump? Not likely, just something I noticed during one of my fuel grade experiments. Others here have reported none of this at all on known routes using premium fuel vs 87 octane. I'm not prepared to go that far just to avoid a downshift on slight hills.
 

·
Registered
Joined
·
2,498 Posts
I will check and test air filter later today. The oil filter was changed... no temperature changes, oil is full and clean.
As others have mentioned, I doubt the oil change did anything, but definitely go over the air cleaner housing and all its attachments.
 
1 - 10 of 10 Posts
Top