Toyota RAV4 Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, I’m new here with my first Rav4. Its a 2007 2.2 d-4d
This morning my engine was on idle and cut out. On the onboard computer i caught a glimpse of “oil press” then the message cleared. I checked engine oil level, that was good, no leaks, no foam under cap. Engine temp ok, coolant level ok and look clean.
i started her back up drove for an hour with no issues and then when coming to a stop the engine cut out again. This time with no warning lights. Started again straight away and got me to work. I plugged in and thereare no fault codes stored.
Do you have any ideas? And have I made sense?
 

·
Registered
2010 2.0 VVTi RAV 4
Joined
·
820 Posts
Welcome to the forum, and sorry to hear your woes.

Your description does make sense. As you have no DTC's, this is a difficult one to think about - especially as it is intermittent.

As you have a code reader, are you able to extract base data fro it and post on here please.

When the engine is warm, can you post data at idle and at 2500 rpm.

Would like to see short and long term fuel trims, air and coolant temps, MAF data, upstream and down stream O2 readings (with these, can you post max and min values over a period of say 120 seconds). These are just initial thoughts that may give direction
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Welcome to the forum, and sorry to hear your woes.

Your description does make sense. As you have no DTC's, this is a difficult one to think about - especially as it is intermittent.

As you have a code reader, are you able to extract base data fro it and post on here please.

When the engine is warm, can you post data at idle and at 2500 rpm.

Would like to see short and long term fuel trims, air and coolant temps, MAF data, upstream and down stream O2 readings (with these, can you post max and min values over a period of say 120 seconds). These are just initial thoughts that may give direction
Thank you. I will see what i can do. I did clean the EGR. Today it cut out 6 times and low oil pressure was on the message only 3 times of the 6. Wondering if its oil pressure or that comes up as the engine dies. Hard to tell.
 

·
Registered
2010 2.0 VVTi RAV 4
Joined
·
820 Posts
I think the oil light comes on just as the engine (and oil pump) stops. I would be far more concerned if it came on when running and remained on !!!!!!

Even with all these fancy sensors, I always prefer the old dipstick to measure oil - as yours is topped up, no worries.

EDR is always a good one, so as yo have cleaned it, it can do no harm at all. I would try to capture the data as above - this may give us direction as we have no DTC's
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Using a mates computer i plugged in and fault codes showed which didn't on mine. UO105 communication lost with injector controller. Wiring looks ok so i think this 30 degree heat has cooked the module as only fails when hot. Ordered a second hand one for £30 to see if i’m right.
 

·
Registered
2010 2.0 VVTi RAV 4
Joined
·
820 Posts
You are on the right track - if the harness is intact, and there are no green crusties on any of the connections, the injector controller is next

Let us know how you get on
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Car had not cut out since the weathers been below 30 degrees. I have just changed the injector controller unit with a second hand one. Car seems to be running ok. Yet to drive it and wait for some 30 degree heat. I hate intermittent faults; i like to known its fixed or it isn’t haha.
 
1 - 9 of 9 Posts
Top